Cheating, are we? in eNewsletter

I'm having huge issues with editing newsletters in eNewsletter for http://www.milkchic.co.uk. I can't edit anything at all in Firefox (needs updating so may well be a browser issue...) as I get a "Cheating, are we?" message every time I change anything at all. I managed to get everything working in Chrome this morning, which is fully up to date. Unfortunately, every time I try to save, I get the "Cheating, are we?" message and lose all my work.

I'm desperate to get a newsletter out this week. Wordpress and all plugins are all latest versions and I'm getting the same error with only eNewsletter activated so I don't think it's a plugin conflict. Any ideas or workarounds please?

  • Predrag Dubajic
    • Support

    Hey @sequin,

    Hope you're doing well today :slight_smile:

    I had a look at your site and here are few things you can try.

    First thing would be reinstalling the e-Newsletter plugin to see if that fixes it.

    Second thing you could try is disabling your caching plugin and any plugins that are minifying js and css files.

    One more thing would be switching to default WP theme so you can check if it's something theme related.

    Please let me know how it goes.

    Best regards,
    Predrag

  • pxwm
    • WP Core Meltdown

    Hi @Predrag Dubajic - our posts crossed

    Hi @sequin,

    I've researched this and there are a few reasons this may be happening but the easiest to check is to revert back to a default theme and test.

    I always suggest taking a full backup of the site before making changes.

    I hope this helps
    Regards
    SteveB

  • sequin
    • Site Builder, Child of Zeus

    Thanks both,

    Just about to do school pickup... but it doesn't appear to be a theme issue and I'm having the same issue with only eNewsletter activated so I don't think it can be a caching / minifying issue either (I use W3TC)? Will try reinstalling when I get back.

    Mel

  • pxwm
    • WP Core Meltdown

    Hi @sequin,

    The problem may be due to incorrect timestamps.
    You may wish trying the following.

    Create a basic post and publish.
    If the post is successfully published could you confirm the timestamp of the post (date and time) by viewing the post and confirm if this matches your local date and time.

    Regards
    SteveB

  • sequin
    • Site Builder, Child of Zeus

    Thanks for the help :slight_smile: Post timestamp does match local time. I disabled minify but no change. The issue seems to have worsened since reinstalling. I can only intermittently edit now but usually am going straight to a cheating error and consistently get the error message on save.

  • Predrag Dubajic
    • Support

    Hi @sequin,

    This is really strange and I must say I'm running out of ideas on this one.

    Could you provide me with FTP access and I will flag this thread for our second level support dev guys to have a look at?

    You can send us your details using our contact form and this template:

    Subject: "Attn: Predrag Dubajic"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Best regards,
    Predrag

  • sequin
    • Site Builder, Child of Zeus

    Thanks Predrag,

    Have sent my credentials. I feel it ought to be something to do with caching but I'm getting the same error with everything deactivated. The customizer is saving fine if I make theme edits, so seems specific to enewsletter.

    Mel

  • sequin
    • Site Builder, Child of Zeus

    That's weird. So something of the caching must have been remaining when I disabled previously, I guess? It's working for me too now so thank you!

    I'll work through the settings now, but at least worst case I can disable W3TC, create a newsletter then reenable in the short term!

    Many thanks for your persistence and support :slight_smile:

  • Predrag Dubajic
    • Support

    Hi @sequin,

    When using caching plugins it's recommended to clear entire cache before disabling the plugin, this might be why you still had issues after disabling it.

    If you manage to figure out which part of W3TC is causing this please let us know so we can see if there is something we can improve in e-Newsletter to resolve this.

    'll work through the settings now, but at least worst case I can disable W3TC, create a newsletter then reenable in the short term!

    You can always go with that :slight_smile:

    Enjoy your weekend!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.