"Checking API settings" reader won't stop blinking

I can't install ultimate facebook as the "Checking API settings" reader won't stop blinking/ won't register my id. Help!