Checkout not working from individual product pages/posts

Hello,

We'll get this website working if it kills me!

On the home page -- if you just click on the green Add to Cart, Checkout works fine.

However, if you click on an individual product, click on Add to Cart, and then go to Checkout, it says there is nothing in the cart. Over and over.

Please help!

Thanks!

Beverly

  • Mrinal
    • Site Builder, Child of Zeus

    Hi @bevthegeek,

    Thanks for your post, hope you're doing well today.

    I tried both you described above & find products are showing in Checkout.

    Can you please try again after clearing browser cache & cookies or with another browser? I tried the situations in Firefox, Chrome, Safari & Opera, every time I found the added product in Checkout.

    Have a nice day, Cheers!

  • bevthegeek
    • Design Lord, Child of Thor

    I cleared the caches in all browsers and, as you indicate, the added product does show in both Chrome and Firefox, but not Internet Explorer. I have attached the files showing my cart and then the next screen which shows no product in the cart.

    It is imperative this shopping cart work in all major browsers.

    Thank you!

    Beverly

  • bevthegeek
    • Design Lord, Child of Thor

    I went back and started disabling plugins. The JQuery Updater apparently is the culprit; deactivating it somehow, magically, allows the cart to work correctly.

    Plugins can be great or a Fail.

    Thank you for your support and sorry to bother you when I should have checked for the plugin first.

    Have a terrific weekend!

    Beverly

  • bevthegeek
    • Design Lord, Child of Thor

    Just as an update, I had someone else try placing an order from their computer, using IE. They had the same problem, even after I had disabled the plugin.

    So I am going in and disabling all the plugins with the exception of martketpress and the wpmudev, since you need that for access -- and will update this ticket appropriately.

    Thanks so much,

    Beverly

  • bevthegeek
    • Design Lord, Child of Thor

    Yes, I am still having problems. Customers of the client are now calling me (yes, he gave them my number) as they cannot complete the checkout process. I have posted the images in the other two posts. Do you need me to repost them here? I can, but it seems like I'm duplicating the same issue now on two sites.

    Thank you,

    Beverly

  • bevthegeek
    • Design Lord, Child of Thor

    I personally am using IE11, but the user in North Dakota was using Safari on a Mac. I switched to the Twenty Fourteen theme, which essentially ruined the site. Can't find products, the cart, anything. It is all messed up now.

    I have sent an email to the client, but this is disastrous for me.

  • bevthegeek
    • Design Lord, Child of Thor

    I also have removed all iThemes themes in case they were the problem, although I don't think just having them in the folder should matter.

    I have tried Simple Market (no products, no cart?), so couldn't test that.

    Tried the Framemarket theme, could get to the products, but no cart.

    So I am not sure what you want me to do at this point. I was really sold on this cart, but if it doesn't work or I have to rebuild (which is confusing -- shouldn't framemarket or simple market pick up the shopping cart?), I don't know what my options are. I have tried other carts, but this one seemed like the charm. Now I don't know what to do.

    Sorry for the rant. I just really need the cart to work.

    Thanks,

    Beverly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.