Child theme not showing changes

I'm having a similar issue to what's described in this thread except I'm working with BP-Daily:

https://premium.wpmudev.org/forums/topic/changes-in-child-theme-are-not-inherited

Here is the site: http://oneworldbeing.com/dev/

First issue, child.css and custom-header.php:

I wanted to modify the header and make the gradient background disappear. This is the pesky code that is being generated:

#header {
background-image:url("http://oneworldbeing.com/dev/wp-content/themes/bp-daily/library/styles/images/default_header.jpg");
}
health #2 (line 599)

I tracked down the culprit in the custom-header.php, line 69:
#header { background-image: url(<?php header_image() ?>); }

I had to make this change in the parent theme, not working in the child theme:
#header { background-image: none; }

Change to background-image: none; was not working in the child.css file either.

Second issue, loop-functions.php

Changes to the loop-functions.php file in the child theme are not showing but they are showing in parent theme.

Thanks

  • Tammie

    @JDubindustries: You need to select a style under preset styles. Currently you have none selected so are using the default one which places CSS in the header and is possibly getting in the way. Custom header changes will not work in the child as if you look in functions.php they are referring directly to that. You can however adjust custom-header.php under functions/

    Similar applies to loop-functions.php where in functions.php they are called by referencing the direct file. You can overwrite them by removing and then adding new actions but as already said in the previous comment if you are not happy with adjusting or creating your own function you would be best to just change in the archive page as it's used on index, archive and other pages because it's the excerpt function.

  • Mason

    JDub, did you try:
    #header { background-image: none!important; }

    Sometimes I've found that I have to add !important for it to override something in an earlier style sheet. I know it's not supposed to have to work that way, but I have seen where it happens and this usually takes care of it for me. Maybe Tammie knows something better :stuck_out_tongue:

    *Edit* And dang-it, she beat me by 10 seconds!

  • JDubindustries

    Thanks Tammie. Found the header settings under Appearance > Header > Remove Image which removed the gradient back ground image, I then restored the parent code.

    About loop-functions.php, so I understand, just putting static text into the child template won't force the system to pick the child template? Only a fully custom loop will force the child to be used instead of the parent? Thank you for suggesting I directly edit archive.php. I am reading up on the loop now and will make a decision about which action to take.

    @masonjames: Avoid !important at all costs. If you're desperate, sure. That's why I posted here!

    Thanks everybody!

  • Tammie

    @JDubindustries: i think you are misunderstanding what I was saying. What I am suggesting is just what I did in the other thread where you just create a new archive page and put your custom loop in there. Loop functions is just a collection of loops made into functions. You can have a child archive but again this is all something you will have to experiment a little with. I was referring to removing the archive loop function IN the archive page and putting your own custom loop there.