Choose service provider for gCal integration

Another question here regarding the Appointments+ plugin. We are having a bit of a problem with syncing across multiple services from the gCal. It appears that when a span of time is blocked off from the gCal side, it will import into the calendar, however it's -only- on one service. The services are supposed to be universal with only one service booked per time-slot. We've adapted to reserve tee times.

So for example we have 4 services (1 Golfer - 4 Golfers). If someone reserves the 10:10AM slot with 4 Golfers, that time is reserved across all services, and cannot be booked again. However, when the booking comes from the gCal sync, the only service that is blocked off is 1 Golfer, but if you choose services 2-4 Golfers, those time-slots are open?

I've troubleshooted to the point that I've found that when a block of time is reserved by gCal, it appears to be booked under a service provider whom is not on my service providers list (under A+ Settings) or one of my WordPress users, which is odd, and the blocked off time is only for one service (1 Golfer).

I did some research and discovered I can set up gCal sync between the specific service provider and gCal, I've attempted to do so. However, even with the setting turned on under A+ settings to allow service providers integration with gCal, it still says under the user that it is disabled and will not let me enter in the information required for API connection. The boxes are a different, more greyed out background and although I can click within the box, I cannot type anything.

I feel like this should be simple and I may be missing something. Once again I'm requesting your excellent help with getting your plugin to fulfill our needs.

  • Vinod Dalvi
    • WP Unicorn

    Hi @Scott,

    Thank you for your detailed question.

    I did some research and discovered I can set up gCal sync between the specific service provider and gCal, I've attempted to do so. However, even with the setting turned on under A+ settings to allow service providers integration with gCal, it still says under the user that it is disabled and will not let me enter in the information required for API connection. The boxes are a different, more greyed out background and although I can click within the box, I cannot type anything.

    Could you please share me the screenshot of what you are getting or tell me a bit more details about the issue like exactly where you are facing it so that i can help you to make it work?

    Kind Regards,
    Vinod Dalvi

  • Jack Kitterhing
    • Code Norris

    Hi there @Scott,

    Hope you're well today, appreciate your patience here, sorry about the delay.

    To save any further delay, could you send me through the following, so I can check everything without needing further information. :slight_smile:

    Please send in the following.

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

  • pxwm
    • WP Core Meltdown

    Hi @Scott

    If I've understood your problem correctly and based on your recent post showing that you can't make changes in a user profile then you may wish to try the following:-

    >To set up GCAL for a specific Service Provider then try logging in as the User/Service Provider in the Wordpress Dashboard.
    This should then allow you to make changes to the sections you have indicated are 'Uneditable' and 'Keeps 'Reverting Back'.

    I hope that helps
    Regards
    SteveB

    • Scott
      • Design Lord, Child of Thor

      Thank you for that. I knew it was something simple I was overlooking. After logging into the user that is being used as the service provider, I was able to create the connection. I then made sure to remove the integration with the plugin itself, and only have it set up through the service provider. Now the appointment gets booked through gCal and is blocked off on all services on my tee time sheet. Thank you @pxwm!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.