Clarify confusion regarding automessage setup

I've read through your instructions and forum and it is still unclear on whether to network activate on multisite.

I have a multisite (as standard, all sign-ups are from main blog), however, also as standard, new signups are not registered users on the main blog.

I want to send the automessages to all new blog sites. I do not need to provide the subsites with the ability to send their own automessages.

It appears from installation instructions that in order to send to new blog sites you need to network activate. However, there are no settings in the network admin. From which site do I create the automessages? I assume, my only choice is the main blog, but the new signups are not associated with the main blog.

Please clarify the proper method for my use case. Is it network activation or per site activation? And which site to use to send messages to all new blog signups?

  • Ash

    Hello @antKat

    I hope you are well today and thanks for asking the question.

    I want to send the automessages to all new blog sites.

    You can try the blog level mesage from the main site. Blog level message will be sent to the users that creates a blog.

    I do not need to provide the subsites with the ability to send their own automessages.

    If you want to hide it from subsite, you can try our Pro Sites plugin (it's huge though) to hide the the plugin from subsites. But note that, subsite admins can't send blog level message.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.