Clear full cache when post/page is updated

I enabled "Clear full cache when post/page is updated" is the Page Caching, but, when I change something on the website, it loads the same page again.

Could it be possible that the plugin wants to change inside the wp-content folder but can't because this directory doesn't exist (I changed it to other directory)?

However, in the wp-config, the following constants were added:

define( 'WP_CONTENT_DIR', dirname(__FILE__) . '/directory/wp-content' );
define( 'WP_CONTENT_URL', 'https://your-site.com/directory/wp-content' );

  • Nastia

    Hello TINT.

    Hope all is well!

    Would you please let us know more information, like what changes are you adding in the page and these are not showing? Is this happens on all pages or only on a specific page?

    I could not reproduce the issue on my test site, with wp-content directory added in another directory root.

    Currently, on your site Page Caching is deactivated, can we activate it so we could see the issue?

    Please advise,

    Kind regards,
    Nastia

  • TINT.

    Hey Nastia,

    I think Luis was not precise enough. Our problem was as follow:

    On Friday I enabled caching on our site and it improved our website speed a lot. But on saturday it began that users where complaining that they can't login on our site (via https:tintyoga.com/log-in). It said: Request failed.

    Wp-Login was still working and I added your membership login shortcode to another page for testing where it worked. I was then talking to Luis on sunday to fix this issue and we figured out that this should have something to do with the hummingbird caching plugin. After deactivating the caching functions the old login page worked again.

    What are my problems now?

    1. I want to enable caching, but somehow the login page returns an error for users. Do you have known issues with this? Maybe it could help to disable caching for the login page?

    2. I want to make hummingbird changes inside the plugin and not via manual ftp changes. When I want to clear the cache for example it gives back an error, something like "couldn't access the wp-content folder, change permissions to 755". I checked it and the permissions for the wp-content folder are 755, but our wp-content folder is called "assets" for security reasons. Maybe the plugin is looking for the "wp-content" folder and doesn't realize the "assets" folder?

    I try to recreate the issue on our prod.tintyoga.com with the login problems. Unfortunately on friday everything worked on our test site with the login which was why I implemented it on our live site.

    Thanks for your help Nastia! Great Support!

    All the best,
    Alessio

  • Dimitris

    Hello there TINT.,

    hope you're doing good today and don't mind me chipping in! :slight_smile:

    I tried to replicate this case in a local site of mine, with no avail though. I've renamed /wp-content/ folder to /assets/ and added in wp-config.php:

    define( 'WP_CONTENT_DIR', dirname(__FILE__) . '/assets' );
    define( 'WP_CONTENT_URL', 'http://single.local/assets' );

    I can see that cache could be enabled without any issues after that. Making a change in a page and then visiting it via a incognito window, was showing the updated content to me, and I was also able to purge page cache successfully, without any permission error.

    Having said that, I'd like you to create a staging environment, meaning a exact and complete copy of the live site. Then, in there, update all plugins and themes, so you run only latest versions.
    Also double check that all directories have permissions 755 (or 750) and all files 644 (or 640). Additionally, make sure that the proper user:group is assigned to all WP folders and files (this varies in each server, default Apache setting is www-data:www-data for example).

    Then try to check above issues once more. If these are still happening, please perform a full conflict test. The concept on this is to disable all other plugins apart from WPMUDEV Dashboard and HummingBird, activate a default theme, and check again. If the issues resolved, then start activating the plugins one by one, checking each time what's going on with caching, until you reproduce above errors again.
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    If you're still struggling after that and conflict test doesn't reveal anything to you, please let us know about what exactly you did already and share some more server credentials with us, to have a better look in the staging site. As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Dimitris"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris