clicking the buy now or add to cart button sends me to a wierd search page

I see the cursor icon in the box I am trying in hasn't been fixed. Not sure if anyone realizes it but there is not cursor reference in the box when you submit a new topic on the forums here.

Anyway, I have an issue which is driving me insane.
When I click on a buy now or add to cart button I get redirected to a search page and it references a double .com .com url being used. I don't get that when clicking anything else on my site. Seems like it may have been a browser hijack or something of that nature but when troubleshooting nothing came up as being on my computer and I have since uninstalled and reinstalled multiple browsers.

I have also removed all plugins and tried just the marketpress on it's own. Same thing.
I have a WPMU site with buddypress and currently the marketpress plugin is deactivated according to my screen but things seem to be working as if they were still on.

Here is a page where the button is located if you would like to see the fun in action.
http://crosseyedgaming.com/store/products/crosseyed-gaming-t-shirt-bronze-eye-log/

Any ideas?

  • Mason

    That is definitely a bizarre one.

    I have to believe it's something up with the permalinks there. I've been testing marketpress on a lot of sites and not seen this happen before.

    Have you tried going to Settings>Permalinks and just resaving the page (you don't have to change anything).

    Let us know if that fixes it for you. Sometimes they get saved incorrectly. If not, we'll have to dig a bit deeper here, but do let us know.

    Thanks!

  • Rick Lewis

    tried that a couple times already but just went in and did it again to make sure.

    Right now I have most every plugin turned off.

    I have a mu-plugins folder with some stuff in it which was there when I had the WPMU install and setup done. Some of the stuff in there was old and not needed as when I upgraded to the new versions beings they installed all the old stuff, it told me to remove things from that directory.

    I doubt anything in there is causing this but i did actually change that folders name so that every plugin was turned off. Even the marketpress is off not and that still ends up going to a .com.com version of my domain. I don't even know what that domainsearchhelp is or how to turn that off. Seems to me like it would generate a normal error page which is why I thought maybe it was a browser issue on my side.

    Surely there is something lingering in some file causing the issue. I can't recall changing anything manually that involved the url path.

    I had some custom theme work done. Could it possibility be in their somewhere?
    And if so, how or why would it only effect this button?

    EDIT __ I just checked and the plugin is in fact turned on for my main blog although it shows as network deactivated. Whomever decided to make two separate areas for the newtork and site needs to have their head examined. Sorry, that was probably not needed on this forum but it's surely a pain in the butt going back and forth.

    I went to my store main page and clicked on the links for products, orders, etc.. They all do the same thing as the buy link button on the other pages. The only links that do not result in going to this .com.com thing are the specific links for the individual product itself. I only have one on there so it would be the t-shirt link that works.

  • Rick Lewis

    Ok so here is another update -- I found the .com.com reference in my config file next two noblogredirect.

    I do not recall ever changing anything in there but I guess anything is possible. I took out the second .com and now things do not go to the domainhelpsearch thing it was going to but they also don't go to the correct page either.

    I click any of the links now and I end up back at the home page.

    Is that no blog thing suppose to be blank??

    Right now the url for my domain is in there. OR, is the issue something else altogether?
    UPDATE __ I just took a shot and removed that line. This works the way it is suppose to work now. The only question I would have it, should that line of code even be there and if so what needs to be in it?

  • Mason

    Hiya Rick,

    Yeah, that was my next item was going to be something in your config settings - just didn't see how it would only affect MarketPress items.

    You absolutely don't need the noblogredirect in your wp-config at all and I don't believe it's ever installed by default. Weird that it was in there, but that'd definitely cause problems.

    Just FYI, it's usage is really for situations where you may not have registrations live on your site and you want folks directed to your homepage rather than the signup page.

    Are we ok to mark this one as resolved?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.