Client upgrade loses initial expiring date

Hi,
when using Pro Sites (Versión 3.0.3),
after a client upgrades from plan A 1 month to plan A 3 month,
it looses the original plan expiring date:
Ex:
plan A starts Jan, 1st. for a month (finishes 1st. February)
then client wants to upgrade for a 3 month plan:
plan A should then finish May, 1st.

instead, plan A monthly is removed, and starts a 3 moths plan on jan, 1st. expiring on April, 1st.
(client is losing 1 month subscription which was already paid).

Is it a bug or a configuration error?
Many thanks,
Carles

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    When a user 'upgrades' their plan they should not be immediately charged. The charge is delayed until the time of their next payment. This means that their plan would say they're on the 3-month plan, with a renewal date one month away. At their next renewal date they will be moved to the 3-month plan (and their access until date is modified).

    I'm attaching a screenshot showing how this looks on the test install I used to verify this.

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.