Clients can't make payments on Appointments+

Hi there,

I've read through different posts here, but even thought I've found a similar issue someone had, my problem still persists.

I'm testing the service and changed the amount for the it to $1, and when I try an make an appointment, it doesn't go to the Paypal page and no confirmation is sent either.

Please can you help!!!

Many thanks.

Viv

  • Michelle Shull

    I Viv!

    I just tested, and I was definitely charged a dollar, but you're correct, I don't see the transaction listed in your dashboard.

    Let's rule out a couple of simple things, first.

    1. Your settings all look fine to me, and you paypal account seems to be set up correctly.

    2. This wouldn't be a theme conflict, since the issue is only on the admin side.

    3. That makes a plugin conflict the most likely culprit. Can you try deactivating all plugins except Appointments+ temporarily, and checking to see if the transactions show up for you? If they do, start turning on your plugins one by one until you find the one that's interfering.

    Let me know how this goes, and we'll move on from there!

  • aristath

    Hello again @Viv,

    Thank you for your patience here until we resolve this and find out what's causing it!

    Also I did what you said an deactivated all the plugins, but none of the transitions showed up.

    Existing transaction will not show up, can you please deactivate all your other plugins and make a new transaction to see if this shows up?
    Just to be on the safe side, could you also switch to the twentyfourteen theme while you're testing this? This way w'll be certain there's not some code in your theme that's preventing WordPress from properly processing these things.

    Please advise,
    Ari.

  • Tyler Postle

    Hey Viv,

    Hope you're doing well today and thanks for testing that out for us!

    I just did a test run in my own sandbox and the transaction showed up as expected. Is your IPN url setup? If not let's get that set :slight_smile:

    I'll post a screenshot for you.

    Go into your PayPal account and navigate:

    My Overview > History > IPN History. If it's not turned on there should be a link there that says "Turn on IPN" then paste in the url from your apps setting (as seen in the screenshot).

    After you have that set, then try another test transation :slight_smile:

    Look forward to hearing back Viv!

    Cheers,
    Tyler

    PS. It should automatically send confirmation; however, since it doesn't show the payment going through, I'm guessing that it thinks it isn't being received so it doesn't switch the appointment to confirmed.

  • Tyler Postle

    Hey Viv

    Thanks for trying that out :slight_smile:

    Do you mind granting support access so we can take a look at your settings and Appointments+ log?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Can you also check your IPN history now that you have it set? You can do that via: My Overview > History > IPN History. in PayPal.

    It should have entries now of the transactions and will provide some information :slight_smile: let us know if any errors are there.

    Look forward to hearing back Viv!

    All the best,
    Tyler

    PS. Would you mind if I tested this using my own sandbox PayPal account? I would have to remove the credentials you currently have in your apps+ payment settings right now.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.