Clientside Admin Theme

Hello;

I was buy clientside admin theme but there are some error this admin theme, I ask someforum but still i cant solve this problems

Firstly there is space area when no logged or logget out,
and this admin theme break sticky topbar some theme (example my kleo theme)

I know this error not about wpmudev but i am realy dont found any answer (i was ask officcal clientside forum)

Thanks! =D

  • Adam Czajczyk
    • Support Gorilla

    Hello Variotik,

    I hope you're well today and thank you for your question!

    I hope I'll be able to help you with this but I need more information. Could you please:

    - tell me which admin theme are you using (a link to the source would be great)?
    - share some screenshots showing issues (with short description) here?
    - grant me an access to your site so I could see these issues myself?

    Here's a guide on how to grant an access:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Variotik!

    Thank you for granting access and sharing these information with me.

    I must say that I'm a bit confused though. In your initial question you referred to the admin theme issues but your screenshots show the front-end of your site which is based on Kleo child-theme. These are two separate themes and I'm not sure what's the connection theme.

    As fro the issue that I can see on provided screenshots.

    There's a top margin added to the HTML element (tag) of the page moving initially entire page down by 92 pixels and as a result breaking other CSS rules settings. I reviewed your site and I wasn't unfortunately able to find out where does it come from despite the fact that the rule for this is served from Hummingbirds cache.

    That said, please try following steps:

    1. Access your setup via FTP (or cPanel "File Manager") and then
    - go to /wp-content/uploads/wp-hummingbird-cache folder
    - delete all the files and folder inside
    - clear your browser's cache and see if it helped.

    If it didn't:

    2. review the child's theme "style.css" file looking for a rule similar to this one:

    html {margin-top:92px!important;}

    If it's there remove it and then repeat step 1.

    3. if this still doesn't help
    - install "Simple Custom CSS" plugin (https://wordpress.org/plugins/simple-custom-css/)
    - go to "Appearance -> Custom CSS" page in site's dashboard
    - put this code inside and save settings:

    html {margin-top:0!important;}

    - repeat step 1

    Let me know if this helped please!

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Variotik!

    Are you saying that the same issue happens to other themes than your current one if the admin theme is active? This would confirm that that additional top margin (of 92 pixels) is indeed added by your admin theme.

    However, I would strongly encourage you to try solution number 2 and 3 because otherwise you would most likely need to change original files of the admin theme and this is never recommended. An additional CSS added the way I suggested will not break admin theme and will not be lost upon theme update so it's the safest way.

    That said, please give it a try and in case it didn't help either I'll find other way.

    Best regards,
    Adam

  • Variotik
    • The Crimson Coder

    Hello;

    I know, this problem about clientside admin theme not child theme or another theme. So ? replace this code in clientside site admin bar css file;

    html {margin-top:92px!important;} >>>> html {margin-top:0px!important;}

    and problem solved little. Now there is no white area when logged out and log in but still there are 92 px to top with sticky header bar. This problem not about theme, i know because i try other themes and there is no white area when i activate other themes but sticky header still bottom 92 px ( ? try with offical wordpress theme twenty sixteen)

  • Variotik
    • The Crimson Coder

    An idea came to mind, you know offical wordpress adminbar always stiky to top, but clientside not stiky. Maybe i do stiky clientside adminbar and after all problem solved.

    What do you think about this idea? do you think I should do it.

  • Predrag Dubajic
    • Support

    Hi Variotik,

    You could give it a try and see how it goes, but my suggestion would be to ask the plugin developers again about the fix since the Clientside CSS is affecting quite a few things with that custom admin bar and could cause you issues in some other places in future.

    Let us know how it goes.

    Best regards,
    Predrag

  • Dimitris
    • Support Star

    Hey there Variotik,

    hope you're doing good and don't mind chiming in here! :slight_smile:

    Could you please create a new MU plugin file, like /wp-content/mu-plugins/my-custom-css.php (simply create the /mu-plugins/ folder if doesn't exist) and insert the exact snippet in there:

    <?php
    function my_custom_css() {
        if ( !is_user_logged_in() ) {
        echo '<style>html {margin-top: 0 !important;}</style>';
        }
    }
    add_action( 'wp_footer', 'my_custom_css' );

    Let me know how that goes!
    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.