Cloner Compatibility issue

Cloner giving the following fatal error when a subsite is cloned:

PHP Fatal error: Declaration of Site_Copier_Pages::copy() must be compatible with Site_Copier_Post_Types::copy($post_id = false) /plugins/cloner/copier/class.copier-pages.php on line 10

Running on 7.2.7-1+ubuntu16.04.1+deb.sury.org+1

It worked fine once PHP version was switched to 7.1.10. Please check the chat transcript for more info.