Cloner not cloning entry in custom table

I am using Paid Member Subscriptions from Cozmo Labs. There is a custom table in each subdomain site in my multisite network (wp_2_pms_member_subscriptions) . When cloning a site, the custom table is created. There is just one row in the table, but it is not cloned.

  • Milan
    • WordPress Wizard

    Hello swsupport

    Hope you are well today and thanks for asking us. :slight_smile:

    Can you tell me what that row is doing on site ?

    Also Would you please grant me support staff access so that I can check in depth regarding your issue ?. You can grant me support access via WPMU DEV > Support > Support Access > Grant Access.

    Kind Regards,


  • swsupport
    • Design Lord, Child of Thor

    Further investigation shows that Cloner is not cloning the post_type pms-subscription in the wp_2_posts table

    and is also failing to clone several entries in wp_2_postmeta table whose meta_keys all start with


  • Dimitris
    • Support Star

    Hey there swsupport,

    I hope everything's going well for you today and don't mind skipping in! :slight_smile:

    I just tried to replicate your issue in my end and I can confirm this. I created couple of subscription levels and assigned a member in each of these. Then I cloned the sub site in another sub site and even though I can see the members, they aren't assinged anywhere as there aren't any subscription levels at all.

    I made sure that all of appropriate settings were applied in Network Admin > Settings > Cloner but still no avail.

    Having said that, would you mind granting us support access to see that in action and have a better insight? You can find details of doing so in

    Meanwhile, I'll go ahead and ping our dev team just in case I miss something and you can you please enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Run a cloning process of main site and this should create debug.log file in your wp-content folder that could tell us what is going on. Save it as .txt file and attach it here so we can check it out.

    Warm regards,


  • swsupport
    • Design Lord, Child of Thor

    Hi – I really can’t do either the debug or grant access – this is a live and very heavily used site at this point. The fact that you could create a similar setup and confirm the issue should be enough for yoiu to get a debug log and get this resolved by the dev team.

    I was able to write some code to insert the subscription level properly into all the sub-sites. To add a bit more – the entries missing in the wp_2_postmeta table include a couple that every subscription adds and several that were added by the global content restriction add-on.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.