Cloner Plugin - Menu structure did not copy over

The cloner plugin worked great, however it did not replicate the main menu structure to the new site. Is this a bug, or not currently included in the plugin? If the latter, is it on the roadmap to replicate the entire menu in its current state including dropdown items?

  • Nastia
    • Support Rock Star

    Hello Lonnie , I hope all is well today!

    Please make sure that the "Menu" option is selected in Settings > Cloner option like it is shown in the attached screenshot:

    I tested the plugin on my site and the menu was cloned to a new site. Do you use another plugin for your menu?

    If the menu option is checked, would you please enable WordPress debug so we could see what causing this issue?

    Place the following to the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Please make sure that you insert this line BEFORE /* That's all, stop editing! Happy blogging. */ in the wp-config.php file.

    Cone a site again. This way all errors will be saved in the debug.log file inside the /wp-content/ directory. Save the debug file as a .txt file and attach it here so we can check it out.

    Would you please grant access from WPMU DEV > Support so I could have a closer look at your site's settings?

    Thank you!

    Cheers,
    Nastia

  • Sajid
    • DEV MAN’s Sidekick

    Hi Lonnie,
    Hope you are doing good today :slight_smile:

    I am glad to know its working for you now and thanks for posting a reply here. I am marking this thread as resolved for now. Feel free to start new thread if you need further assistance.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.