Cloner redirects to login - Cloning doesn't start, only logs to main site

Cloner is not working for me. After setting up url and title for new site and clicking 'Clone site', it only redirects me to https://newlycreatedsiteurl.mainsite.com/wp-login.php?redirect_to=https%3A%2F%2F newlycreatedsiteurl.mainsite.com%2Fwp-admin%2F&reauth=1
Then afrer login, it logs in to mainsite.com/wp-admin

Now when I try to create or clone site again with that name, it says "The blog already exists". But actually theres is no blog created.

I have tried deactivating all the plugins. I think it's someting with my hosting and their strict security rules or something.

My multisite is hosted on local premium WP-hosting. (Not any popular WPengine etc.) Site uses nginx so I can't do any htaccess changes and dont know about nginx congfig. I can provide a link for their docs with email if you need?

I have also granted access and I would be happy to get this working asap. Let me know if you need any other details.

EDIT:

I found out theres custom.conf-file where I can put custom NGINX rules. Here's what's there now:

### This file is appended into end of nginx server {} block
### It contains any nginx customisations needed for this site
### Those may include eg. custom headers or redirects

###
## Example redirection
###
#rewrite ^/original http://example.com/new/url/ permanent;

###
## Force https and send headers that tell browsers that https is always preferred
###
#if ( $ssl = false  ) {
#  return 301 https://$http_host$request_uri;
#}
#add_header Strict-Transport-Security "max-age=63072000;";

###
## Disable caching completely when developing the site
###
#add_header Cache-Control "no-cache";
#add_header Cache-Control "no-store";
#add_header Pragma "expire";
#add_header Expires "0";

###
## Activate pagespeed postprocessing
## (Optimises&Minifies responses for Better loading time)
###
#pagespeed on;

Should I put something here to maybe get Cloner to work?