[CLONER] Sub-Site on subdomain multisite network taking "ownership" of primary network

This might not be a Cloner issue, but it's what I was reported as being used when the issue began.

One of my asst designers was cloning our Vanilla store, on a multisite with a few dozen stores. He said the clone produced an error, so he deleted it and created another one.
Unfortunately,
1) he didn't take note of the error (I didn't see anything in the logs)
&
2) he didn't try and re-clone over the erroneous new one. instead, he created another

I've given him the third degree on both items... but that doesn't fix my issue.

The problem is that the most recently created multisite seems to take control over some of the core WP Network files. I've tried removing the site, and then the core files refer to the most recent subsite that exists.

So:
- he created site 28, with issues. so he deleted 28.
- he re-cloned our Vanilla site, which became site 29 (that had no apparent issues within itself)
then:
- i then noticed that the cookies set in async Domain Mapping weren't keeping us logged into our main network site. subsites seem to hold the cookie just fine. (i tried uninstallation, reinstallation, with no resolution)
- i looked through the database, and nothing stuck out at me (but i didn't look through *everything*. only the core MultiSite tables)
- i also tried removing/re-installing a few other plugins, with no luck
- ...because, ultimately the problem is that I cannot use Network installed plugins... because it won't save the settings!!! Smush, Hummingbird, etc

oddly enough, clicking on the X on the sign-in box (and not signing in again) makes the box disappear and we're still logged in to the Network site

Fortunately, we're rebuilding another website and are slowly moving over the subsites from Site A to Site B.

So:
- I moved over 29(A) from Site A, to Site B.
- I deleted site 29(A) from Site A
- Now, Site A Network is trying to pull Core files from site 27(A). (everything is fine on Site B)

Now, I realize that this might sounds a bit confusing... so I"m going to post a screenshot of the Chrome error console in my reply.

  • splaquet
    • The Incredible Code Injector

    Something new, that I hadn't noticed before. Within the last hour, I tried clearing out the cache, transients, etc. I then made some humming tweaks in Site 27(A)... which saved on the Network level. Up until just now, I wasn't able to save Hummingbird settings on the network level. So, Site 27 seems to have control... although, I cannot see all of the network wide plugins & settings on Site 27, so i can't 'adjust' the network properly.

    FYI, I've granted support access, but, mind you, this is a very active and *live* ecommerce website. Not that you would, but please don't tweak anything that could have a massively negative effect.

    *NOTICE THE BROWSER'S URL & THE URLS IN THE ERROR CONSOLE, IN THE FOLLOWING SCREENSHOT*

  • splaquet
    • The Incredible Code Injector

    random note here... not sure why i hadn't tried this before, but I tried going to the network level of that subsite that keeps being referenced... AND IT WORKED! so, i'm at least able to edit my network wide settings now.

    using this works:
    https://marcuskingband.hilinemerchandising.com/wp-admin/network/admin.php?page=wphb-caching

    but, using this doesn't:
    https://hilinemerchandising.com/wp-admin/network/admin.php?page=wphb-caching

  • jnkfrancis
    • Recruit

    Hi Splaquet,

    It seems whatever the bug is that is causing your problems is also interrupting the support access. Could you provide us with login credentials so that we can access your site directly? It also sounds like we may need to have access to your error logs and some server level information, so if you are able to provide us with that information that would help us troubleshoot the issue.

    Since this is public forum, you must send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question
    using this template:

    Subject: "Attn: Jeremy"

    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password/path of site in question)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Make sure that my name is in the subject line so that the information get's assigned to me.

    Thanks!

    Jeremy

  • jnkfrancis
    • Recruit

    Hi Splaquet,

    Thanks so much for your patience. You have an interesting situation here and I will do my best to break it down for you :slight_smile:

    First up I took a look at your error log and it is growing really fast. At the time of this post it was over 5GB. I had to turn it into a back-up so that I could download a portion of the log to view it. In the section of log I reviewed it seems that your primary conflict is with your Pro theme:

    [19-Nov-2018 05:56:28 UTC] PHP Warning: include(): Failed opening 'a.php' for inclusion (include_path='.:/usr/share/pear:/opt/alt/php72/usr/share/php:/opt/alt/php72/usr/share/pear') in /home/hilinemerch/public_html/multi/wp-content/themes/pro/cornerstone/includes/elements/mixins_setup/_anchor.php on line 28

    That is one of many errors in the log related to your theme. A very good place to start would be to disable this theme and activate the default Twenty-seventeen theme, then come back and see if you experience the same results to confirm that the theme is the only issue.

    If the problem still persists then we will need to do a full conflict test.

    To Perform A Conflict Test

    First, you till want to create a backup in case you lose any settings during the test and have to restore to a previous working state.

    Then deactivate all plugins and MU-plugins apart from WPMUDEV Dashboard and Hummingbird, Smush and Defender. Then clear all caches and check again if the problem persists. If not, it means that another plugin is conflicting, so start activating the remaining plugins, one by one this time, checking every time for the reported issue, until you reproduce the issue, thus finding the conflicted combination.

    The following flowchart image can assist you during this test: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Since this is a live website with traffic, it would be a good idea to create a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, and perform the test in there instead without worrying about the live site.

    Reference: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Regarding the looping and account switching, early on in my investigation, I did experience odd redirect exactly the way you had described it. However, it has stopped and I can't reproduce the issue. Did you happen to change anything on the site in the past few days? If you are able to test your site and see if temporarily changing your theme resolves the issues mentioned above, that will give us a good place to start.

    Test the site for conflicts starting with the theme and working your way into the plugins and let us know if that resolves the issue.

    Have a great day!

    Jeremy

  • splaquet
    • The Incredible Code Injector

    My apologies on the delayed reply. I've been kinda nutz over here :disappointed:

    Yeah... Those errors are quite the pain. I noticed them when a "rouge" SmartCrawl error was taking my site (then more sites, and more...)

    I wasn't sure what was going on exactly, but after a little help from Ash and a ton of research, it appears that a CloudLinux software/charset/DB issue was creating those errors.

    Ash pointed out that some of the SmartCrawl errors were referencing files that weren't there. That, somehow, the PHP call was calling the code line, but replacing some of the characters?! I then started seeing it happen on the Pro theme files. Fortunately, and magically, the site still works!?

    I found a few references on cPanel/CloudLinux forumsm, on MySQL, NDO & PDO and conflicts. I even went to CL support, but they voting figure it out. They recommended setting MySQL back to Utf8 (from UTF8mb4) and back to their default latin DB collation.

    Anyhow, after more research, I found what I thought was the answer. That was to disable some PDO extensions in the CloudLinux PHP selector.

    After resetting things, configuring and rebuilding MySQL... Those errors had finally gone away, but I hadn't cleaned out the error.log. So, a lot of that old stuff was there still.

    Anyhow, it started kicking out bad character interpretations again... and now, we're in the thick of Black Friday madness

    So, long story short, I need to hold off for a little bit. Thank you for looking into it for me.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.