Cloner - white site when overwriting

Hello!

When initially using the Cloner plugin to create a new site, this works brilliantly. However, when trying to clone/overwrite an existing site, it just turns white. How can I solve this?

Thanks.

  • Kasia Swiderska
    • Support nomad

    Hello Anders,

    Does the white page shows in admin and/or front end of the subsite? White page usualy means that there is some kind of error, so it needs to be debugged. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see content of the debug.log file - so please paste it to the text file and attach to post.

    kind regards,
    Kasia

  • Anders
    • The Incredible Code Injector

    Hi,

    I get a lot of these:
    [07-Jul-2016 18:28:48 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0

    I can't find the debug.log anywhere. Only the error_log, mentioned above. When setting WP_DEBUG_DISPLAY to true, I still get nothing.

    Also, when I did the clone all my foreign characters got messed up.

  • Nithin
    • Support Wizard

    Hi Anders,

    Hope you are doing good today. :slight_smile:

    I wasn't able to replicate this in my test server. I then tried to create a test subsite wpmutest in your install, and then tried to overwrite your mainsite to it. I didn't get any error related to starting the Cloner, as mentioned above. Also the foreign characters seems to work fine too. But due to limited support access, I was logged out form the process. So not sure whether the Cloner would have successfully completed it, or not. Could you please check the test subsite, and see whether there is any glitch?

    If you still find issues. Could you please try increasing your memory limit, and check whether it makes a difference.

    upload_max_filesize = 200M
    post_max_size = 300M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    For eg: You'll have to add the above rules in your php.ini file, and then add the file in your root folder. Please check this link to know more about increasing your memory limit: https://premium.wpmudev.org/blog/increase-memory-limit/

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Anders
    • The Incredible Code Injector

    Hi,

    thank you. This seemed to help, my execution time was way too low:slight_smile:

    Is it possible cloning without the upload folder? This tends to take a very long time, and would be a lot quicker doing it by FTP.

    Thanks.

  • Nithin
    • Support Wizard

    Hi Anders,

    Is it possible cloning without the upload folder? This tends to take a very long time, and would be a lot quicker doing it by FTP.

    If I'm not mistaken, you can find all the option for the content to be copied under Settings > Cloner. Unchecking the Attachments, would exclude all the files related to media library.

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.