Cloning main site with Cloner

Hello there,

I am having issues creating a staging enviroment for the main site in my multi-site network. I am not sure what the procedure is to replicate the main site. Does one have to create the subdomain on the hosting provider before creating that site? Where are the instructions to do this? I will open up the site for "heroes" to take a look and try to replicate the site.

  • Adam Czajczyk
    • Support Gorilla

    Hello Clifford,

    I hope you're fine today!

    As long as your Multisite is working (you are able to create sub-sites) there's no need to create any sub-domains or interact with hosting provider.

    Take a look at this page please, that's a usage guide for Cloner:

    https://premium.wpmudev.org/project/cloner/

    It will give you all the information about how to use this plugin.

    Here's a complete step by step guide on setting up a staging environment within Multisite using Cloner:

    https://premium.wpmudev.org/blog/set-up-staging-site-cloner/

    Take a look at these resources please and I think you should be able to proceed. In case you had any further questions, let me know please.

    Best regards,
    Adam

  • Milan
    • WordPress Wizard

    Hello Clifford

    Hope you are well today and won't mind me chiming here. :slight_smile:

    Could you please disable debug mode to your site and try to clone your site ? To disable debug mode to your site, please open wp-config.php file and find this line,

    define ( "WP_DEBUG", true );

    replace it with these ones,

    define ( "WP_DEBUG", false );

    Once you are done with these changes, try to clone if you still get the error, open wp-config.php once again and add this line at the end of the file

    error_reporting( 0 );

    save the file and try again.

    Let me know how it goes. :slight_smile:
    Best Regards,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.