Cloning process is still running after 6 days

I have a multisite installation and I’m trying to clone my main site to a subsite but 5 days have passed already and it still copying, the process seems to be still running since new images are continuously, although very slowly, added to the list.

FYI, the main site has 1894 items in the media gallery and 777 WooCommerce products

  • Panos
    • SLS

    Hey there joe ,

    I tried to clone a new site on your installation but I get different issue now.

    I get an error message as a response on each try. Also I notice some messages in the console which appear if something goes wrong in the ajax call.

    I would like to investigate this new issue deeper, but as I see in the logs that on 2018-06-26 there was a successful copy completed with cloner, could I have permission to network deactivate some plugins if you haven't already done a conflict check? I believe there is some sort of conflict that causes unpredictable results here.

    Kind regards!

  • joe
    • WPMU DEV Initiate

    yes you can.i made a restore to my account to my host provider due to mistake.the clone proccess was complete but it didnt copy the images thats why i did a roll back to do it again anf after that the clone doesnt respond

  • Panos
    • SLS

    Hi joe ,

    Apologies for delay! Thanks for confirming!

    I have network deactivated most plugins so Cloner has started cloning. I'll wait to see how long it takes to clone those images (1918). In the meantime if you need the plugins network active please let me know so I can re-activate them.

    Once the cloning has completed I'll check which plugin causes the conflict.

    Kind regards!

  • Panos
    • SLS

    After a few tests it seems that the plugin that conflicts is the WooCommerce Print Invoice & Delivery Note. I'll download this plugin and do some test on my local site and will keep you updated.

    Something else that I noticed is that some other plugin causes a lot of delay. I haven't managed to spot that one yet. I'll check that after current issue.

    Kind regards!

  • Panos
    • SLS

    Hey joe ,

    I downloaded that plugin and could replicate this issue on my local test site too.

    The following snippet seems to do the trick :

    add_filter( 'pre_option_wcdn_pro_welcome_page_shown', function( $value ){
    	if ( ! $option = get_option( 'copier-pending' ) ){
            return;
    	}
    	$value = 'wpmudev-to-be-removed';
    
    	return $value;
    });

    In order to test it you can create a mu-plugin and paste that file in there. In case you are not familiar with mu-plugins, they are php files that can be inserted in the wp-content/mu-plugins directory (if that folder doesn't exist you can simply create it) and they are executed without activation. You can read more about mu-plugin here:
    https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    Of course please let us know if you would like us to create that mu-plugin for you :slight_smile:

    Kind regards!

  • Panos
    • SLS

    Hi joe ,

    I'm sorry I didn't explain very well. I see you have inserted the snippet in a php file. Only thing you forgot was to add an opening php tag (<?php) at the file. I have added it now.

    However it still doesn't work on your site when I reactivate the WooCommerce Print Invoice & Delivery Note it still doesn't copy. You see in my test site the issue wat that this plugin would try redirect on admin_init action if a specific option is not set. That redirect doesn't allow Cloner to copy.

    The snippet I provided filters this option so it doesn't redirect. That worked on my test site. It seems there is something additional happening on your site. I would need to do some deeper debugging on your site though and I would need your permission for that. If this is not a staging/test site (a similar site on same server where we can replicate this issue), I would suggest to create one and share admin and ftp access to that one. Else I would need you to confirm that you have kept a backup of you site so I could continue debugging on your site.

    In case you create a staging site and need to send us your credentials, please do not send them from here for security reasons. You can send admin and ftp credentials of your staging site privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:Subject: "Attn: Panos Lyrakis"

    - Admin login:
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    - link back to this thread for reference

    Kind regards!

  • joe
    • WPMU DEV Initiate

    hello pano goodmornibg i try to enter c panel and gives meInternal Server Error
    500

    The system failed to open the session file “/var/cpanel/sessions/raw/mymegast:laxDLOZIn3KaVuBp” because of an error: No space left on device at /usr/local/cpanel/Cpanel/Session.pm line 269.
    cpsrvd Server at c35032.sgvps.net

    also all the sites doesnt work

  • Panos
    • SLS

    Hi joe ,

    I haven't seen this error before, it sounds like some host limit has been exceeded.

    Only way, that I can think of, is to ask your host to increase the limit on your site, or check if there is something to delete. Eg if you were cloning, perhaps there were too many images (about 2000 images ) so there is no disk space, so in this case you can explain which folder host can empty. Or if you were creating a new staging site perhaps ask him to delete the files of the new site.

    Please let us know what host says!

    Kind regards!

  • Panos
    • SLS

    Hi joe ,

    i tried again for 5 days were cloning but again nothing

    I just tested and again it did complete the cloning process. It does take some time as there are many images and some might be large files.

    Only reason for it taking days would be if you closed the browser tab/window before it completes. This works with ajax and it requires the tab/window open until it completes.

    Could you do another test and confirm that you didn't close that tab? It might take some time though, perhaps an hour or even more.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.