Closing popup by clicking on background doesn't set cookie

In PopUp "Additinal Settings" of "Display Settings" section in Hustle, there's an "Expires" option to set. The value there only takes effect if either the "Add Never see this message again link" option is enabled and the user clicks that link in the popup or if "Close button acts as Never see this message again" option is enabled and user closed the popup by clicking on "Close" icon.

This might be confusing so it would be good if there was a line of explanation added in the plugin or the setting would only get activated if one of these options is set.

However, even if "Close button acts as Never see this message again" is enabled and "Clicking on the background does not close Pop-up" option is disabled, only clicking on "close button" sets a cookie so the user doesn't see the popup again. If the popup is closed by clicking on a background, the cookie is not set and the popup loads again.

In this case, clicking on the background should be equivalent of clicking on the close button and should also act as "Never see this message again" or there should be an additional option to set enable/disable background to act as "never see this message again" as well.

  • Nahid

    Hey Elliot !
    Hope you are having a great day!

    This request has been escalated to our Second Level Support team and developers. They'll be back to us with confirmations if this is a bug, clues and workarounds (if possible) in this ticket (or we'll be updating the ticket as soon as we hear back from them internally). Please note that the response time of the Second Level Support team or developers might be a bit delayed than that of the general support staff. We really appreciate your patience and consideration regarding this.

    Kind regards,
    Nahid

  • Ari

    Hey Elliot !

    Hope you have a great day!

    I did a small modification in our plugin, which will set the cookie when you click on overlay. Please follow the below steps to update with new file.

    1: From cPanel or with FTP go to this directory: plugins/hustle/assets/js
    2: Change the front.min.js file to old.front.min.js - just for backup purpose.
    3: Now unzip the attached zip file & upload the latest front.min.js file.
    4: If you have any caching plugin, please remove the cache.
    5: If you use Cloudflare, then purge cache from Cloudflare too.

    It works fine for me, please check is it works fine too from your end.
    And let me know if you have any problem regarding this.

    I have also forwarded this fix to plugin developer so they can review it for future releases.

    Best Regards, Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.