CloudFlare error 522 on new image uploaded

I created a new entry on my blog, here, but the image does not show.

When I check the code, the URL to the original image works just fine (original image), but the resized image at 487×1024 does not work (resized image) and throws an Error 522 on CloudFlare.

Going to the listing of projects, (here), a thumbnail for the image at 240×240 shows perfectly (image of 240×240).

So, original shows, 487×1024 does not, but 240×240 does.

Here is what I have tried so far, according to several suggestions I found in the network:

1. I have already paused CloudFlare, but the image still does not show.

2. According to CloudFlare, is a request error on hosting provider. However, all else is working and only the new image is not being displayed.

3. There might be a resources exhausion. Checked the logs, nothing in there. Nevertheless, I raised the limits at the php.ini for the next variables: memory_limit=96M, post_max_size=20M, upload_max_filesize=20M. Still, problem persists.

4. There might be a problem with the image handler. So I added the code found here and used Regenerate Thumbnails. Not worked either.

5. Downloaded the file by FTP and checked it displayed correctly, so image is not corrupted and URL is correct.

6. Disabled caching plugin to test recent changes on theme and functions. Not worked either.

So, I am running out of ideas as to why is that image not displaying correctly.

Any help is greatly appreciated :smiley:.

*EDIT* I have uploaded a new version of the image in jpg format and repaced it in my post. However, the before image is still there. I wonder if the only solution is to upload the image again (shall I have this problem with previpus image, is gonna be bad).