Comment area not opening up, using Comments Plus

Howdy WPMUDev,

I have Comments+ configured, but the comments section doesn't seem to be working. Jetpack is installed, but I turned off their comments feature in favor of this one. As long as it works, I'm good either way. But I'm more familiar with yours.

What do do?

Thanks,
Joe

  • Nastia
    • Support Rock Star

    Hello Joe, I hope you are doing well!

    I can't replicate the same on my installation, the Comments Plus is working well!

    There are several JS errors in the developer console like:

    Uncaught TypeError: Cannot read property 'type' of undefined(…)

    Failed to load resource: the server responded with a status of 404 (Not Found)

    Because of these errors, would you please run a quick check for a conflict with another plugin? Deactivate all other plugins and test if the comments are showing up and working. If everything is well, activate one plugin at a time to find the one that causes this.

    Please also test for a conflict with a theme, switch to a default WordPress theme, for example to Twenty Sixteen and check the comment section.

    Follow the steps from the flowchart:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it goes.

    Kind regards,
    Nastia

  • Nitrous Cloud
    • The Crimson Coder

    Thanks Nastia,

    I deactivated plugins and it behaved the same.
    When I went to the 2015, the comments opened up.
    I tried the comment feature for Jetpack and the results were identical.

    When I clicked on the "Comments" tab in the sidebar, it posted an error. So I went back to 2015 and then it worked. When I came back to the Issue theme, the comments tab worked, but the feature still isn't working.

    Final results would seem to indicate a conflict between your Issue theme and Comments+ plugin.

    I can use Jetpack if that's going to be a better option. Please let me know what you think.

    Thanks again,
    Joe

  • Sajid
    • DEV MAN’s Sidekick

    Hello Nitrous Cloud,
    Hope you are doing good today :slight_smile:

    I am unable to replicate this issue on my own site too using Issue child theme of Upfront and Comments+ plugin version 1.6.7.

    All services, works fine for me on own site see below screencast:
    https://monosnap.com/file/PLM3ZajG0shw2xtWLlrk5UjtYm599a

    On your website, it does show up all the tabs as you can see in the attached screenshot.

    However, I noticed some issues on your site too. First you need to configure API key for googles maps. You can create one here and add it in Upfront -> General -> API Keys -> Google Maps.

    Once you have this configure then try again. If you are still getting issues then you would have to configure your apps correctly too. I saw that Facebook app is still in development and not live (see screenshot taken from your site).

    Also, please note that, I briefly deactivated JetPack plugin and disabled Custom Comments Template add-on of Comments + plugin (this was the reason of not showing up).

    I have restored the site afterwards.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Nitrous Cloud
    • The Crimson Coder

    Hi Sajid,

    Thanks. FYI, deactivating and reactivating Jetpack requires signing back into it, so it wasn't working properly until I was able to get back to the site. it's still in development, so no biggie.

    The Comments+ plugin requires configuring Google maps? I thought it was optional, so just ignored it.

    I"m trying to decide whether to leave jetpack running or just ditch it. I know others have commented that there are various conflicts.

    Thanks for your help. Not sure what to do, but it sounds like I'm able to narrow down my options. Hopefully my other two tickets will get responses soon too.

    Regards,
    Joe

  • Sajid
    • DEV MAN’s Sidekick

    Hello Nitrous Cloud :slight_smile:

    Yes, I noticed that after activating the JetPack plugin. Sorry about it. But it was required to troubleshoot this issue.

    It is not required but to eliminate the jQuery conflicts, its best if you set up Google Maps API key (both uses JavaScript to function properly so it is kind of required).

    Also, on a side not, now Google Maps API key is required for Maps to work on your site.

    As of June 22, 2016 we are making the following changes to the Google Maps APIs Standard Plan:

    * We no longer support keyless access (any request that doesn't include an API key). Future product updates are only available for requests made with an API key. API keys allow us to contact developers when required and help us identify misbehaving implementations.
    ...

    https://googlegeodevelopers.blogspot.com.au/2016/06/building-for-scale-updates-to-google.html

    Yes, you would have to decide what plugin you should be using on your website, best if you decide in early stages of development.

    I already replied on one of your other thread and you should also get responses for rest of your tickets by our support staff members as soon as possible.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Nitrous Cloud
    • The Crimson Coder

    Okay, why is it working for you and not for me? :O

    I turned off Jetpack and activated Comments plus. Google maps API taken care of. Facebook live now. Still, I see nothing for the comments section. Sorry, I feel like I'm missing something obvious or should be getting this, but it's confounding me.

    http://clip2net.com/clip/m533746/c5849-clip-4kb.png?nocache=1

    As you can see, nothing. Can you please let me know if you're seeing them again? I saw your screenshot. Looked great! Like it was someone else's site. :stuck_out_tongue:

    What am I missing?

    Thanks
    Joe

  • Nitrous Cloud
    • The Crimson Coder

    Oh!! I thought I remembered where you said the reason it didn't display, so combed through again. found it!!

    Also, please note that, I briefly deactivated JetPack plugin and disabled Custom Comments Template add-on of Comments + plugin (this was the reason of not showing up).

    Thanks!! Haha, woot!!

    Okay, any way to make the fonts for each social user option show up without getting cut off like that?

    Thanks again!
    Joe

  • Sajid
    • DEV MAN’s Sidekick

    Hello Nitrous Cloud,
    Hope you are doing good today :slight_smile:

    To display the full label text of social media services. Try adding following code in style.css file of your child theme or using Simple Custom CSS plugin.

    ul#all-comment-providers li a {
        height: 45px !important;
    }

    Also, if you have any more questions then please create a new thread for each one so we can address those in their own tickets.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.