Comment not show on page

Why my comment did not show up on the page, even though Setting -> Discussion, Allow people to post comments on new articles is ON? Please advise... Thank you

  • Adam Czajczyk

    Hello Suhartono

    I hope you're well today and thank you for your question!

    I understand that the comment form shows up but just comments are not appearing after being submitted, right?

    That usually depends on settings. A common options are that "Comment must be manually approved" and/or "Comment author must have previously approved comment", sometimes both at once are enabled.

    The second one means that if the user never commented before, their first comment must be manually approved by an admin before it shows up and so their next comments could automatically appear on site.

    The first one means that each and every comment must be manually approved before showing up on site.

    You can check these settings on "Settings -> Discussion" page of the (sub)site in question.

    Comments can be approved on "Comments" page in back-end of the (sub)site.

    Another possible reasons are that either comment contains more than allowed number of links (see "Hold a comment in the queue if it contains X or more links..." option on "Settings -> Discussion" page) or that there's some anti-spam plugin (e.g. Akismet or similar) that detected that comment as a spam. In both cases you would find those comments on "Comments" page in back-end as well.

    These are just most common reasons so start with checking them, please. If that still doesn't help, please enable support access to the site so I could take a closer look. To do this, please go to the "Network Admin -> WPMU DEV -> Support" page in your site's back-end and click on "Grant support access" button there. Then let me know here about which of the sites of the Mutlisite is/are affected and which user account was used to post the comment(s) in question.

    I'll then investigate the issue.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Suhartono,

    Thank you for granting access.

    I've accessed your site and added a comment to "Welcome to..." post on a main site of your Multisite. The comment got added and is showing up there. Other than this, on "Comments" page in the back-end I can see 2 other comments that were marked as SPAM but I believe these are not the ones in question.

    I'm not sure then where/what should I look at/for. Can you tell me please exactly where should I go on your site and what to do to replicate the issue that you're experiencing? I realize that "adding comment" seems pretty straightforward but I need to be able to do exactly the same thing that you did - in order to be able to test it.

    Let me know please and I'll check it again.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Suhartono

    Thank you for your response.

    I have checked your site and I believe I misunderstood you slightly, I'm sorry for that.

    The comment for "Welcome to... " post was added by me right before I posted my last message here and it was added properly (the fact that there's your name next to it is because of how Support Access feature works - it logs me as "you", a super-admin of the site). I've added another one just now and it worked there too.

    But the problem that I missed is not that comments are not appearing but that the comments form was not even visible on other posts. That is because if you had comments disabled on "Settings -> Discussion" page before, then enabling them there doesn't automatically apply to already existing posts.

    I'm referring specifically to the "Automatically close comments on articles older than" option. Since you have changed it, all the new posts will have commenting form enabled (and you can see it in "Test post" that I created on the main site, you may remove it of course) but for already existing posts you will have to manually enable comments:

    1. go to the existing post
    2. make sure that in "Screen options" tab at the top of the screen the "Discussion" check-box is checked
    3. then in "Discussion" meta box on post editing screen check "Allow comments" option and update post
    4. repeat these steps for all already existing posts

    This will open comments for these posts and comments will appear on them.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hi Suhartono

    I'm glad it's working for you know :slight_smile:

    The "Discussion" option on edit post screen - that might sometimes be hidden (actually, by default it is) so you might need to enable it first. You do this by clicking on "Screen Options" tab in upper-right corner of the screen, while on post editing page. That gives you a set of checkboxes to show/hide various parts of that editing screen:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.