Comments + and DIVI theme not working correctly

Hi,

I'm having issues again with Comments + and the DIVI theme. I thought I had this working, but for some reason, can't seem to make work properly.

I've following the fixes from the following thread and have added the code snippet to my themes custom.js file.

https://premium.wpmudev.org/forums/topic/comments-plus-hooks-and-divi-by-elegant-themes

When I add the code to the custom.js , I get the following errors:

Uncaught ReferenceError: $this_link is not defined
at custom.js?ver=3.0.19:1266

I don't remember getting these in the past. The comment box appears, I see the social logins, tabs, etc... the issue is when I click on any of them, the comment box doesn't open and the page slightly scrolls to towards the top.

Anyways, any help would be greatly appreciated. I'm sure I'm just missing something silly :slight_smile:

Thanks!
Shayne

  • James Morris
    • WordPress Enthusiast

    Hello Shayne,

    I hope you are well today.

    In order to help you better with your issue, would you please grant me access to your site and server so I can look at the customizations that have been added and troubleshoot this issue?

    Please visit the Contact page and complete the form with the following information:

    Select "I have a different question" from the drop-down box.

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Shayne,

    I sincerely apologize for the delay and any problems this may have caused you.

    I've been able to resolve this issue for you.

    In wp-content/themes/Divi/custom.js, I commented out the following line:

    //disable_scroll = has_closest_smooth_scroll_disabled || has_closest_woocommerce_tabs || has_closest_eab_cal_link || has_acomment_reply;

    Then, I added the following:

    // WPMU DEV FIX
    comments_wp = $this_link.is( '#comment-provider-wordpress-link' ),
    comments_twit = $this_link.is( '#comment-provider-twitter-link' ),
    comments_fb = $this_link.is( '#comment-provider-facebook-link' ),
    comments_gp = $this_link.is( '#comment-provider-google-link' ),
    
    disable_scroll = has_closest_smooth_scroll_disabled || has_closest_woocommerce_tabs || has_closest_eab_cal_link || has_acomment_reply || comments_wp || comments_twit || comments_fb || comments_gp;
    // END WPMU DEV FIX

    Now, you are able to tab between the different social networks.

    Let us know if you have any further issues. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.