comments form isn't working on blog

I've done some extreme customizations to the gridmarket theme but my customizations have been primarily CSS styles and I added the code for a gallery widget on the home page. In other words, I have not altered the templates ... only the custom style sheet and functions.php.

When I add a blog post to the site, The comments template is "kind of" there but the behavior is different than the default gridmarket theme and I just can't work out what is the problem.

Here is the url to the site under development:
http://mildlymystified.com/holstar/devsite/

Any help would be greatly appreciated. My eyes are spinning in my head...

  • virtuallymarj

    Hi Phil,

    No ... GlucAffect is just a demo post with content from a previous development.

    Here is my list of active plugins:

    Dynamic Content Gallery
    Embedit
    FV WordPress Flowplayer
    MarketPress
    Quick page/Post Redirect DEV
    WP Maintenance mode
    WPMU DEV Update notifications
    Wp No Category Base

    I can't see the cancel reply link in Firefox or Chrome. What would be causing that?

    Can you tell me what script calls the comment form?

    Other than the marketpress scripts that are included in gridmarket, there is only comments.php, custom-styles.php, footer.php, header.php, sidebar.php and index.php in that folder.

    Here is the code for index.php

    <?php get_header(); ?>
    <div id="content">
        <?php // checks to see if the Dynamic Content Gallery plguin is enabled - if it isn't, nothing will diplay ?>
        <?php if (function_exists('dynamic_content_gallery')) : ?>
    		<div id="dynamic-content-gallery">
    			<div class="gallery-widget">
    				<h1 class="post-title"><?php _e( 'Featured products', TEMPLATE_DOMAIN ) ?></h1>
    				<div>
    					<?php dynamic_content_gallery(); ?>
    				</div><!-- end gallery-widget -->
    			</div><!-- end .widget -->
    		</div><!-- end #dynamic-content-gallery -->
    		<?php endif; ?>
    			<?php if($bp_existed == 'true') : ?>
    			<?php do_action( 'bp_before_blog_home' ) ?>
    			<?php endif; ?>
    	<?php if ( class_exists( 'MarketPress' ) ) {
    		?>
    		<?php  if ( is_multisite() ) {?>
    			<?php
    				$options = get_option('framemarket_theme_options');
    				$showpicker = $options['showinput'];
    				if ($showpicker == "Global"){
    					?>
                        <div id="mp-product-grid">
    						<h1 class="post-title"><?php echo framemarket_page_title_output(); ?></h1>
                                <?php
                                    $args = array();
                                    $args['echo'] = false;
                                    //check for paging
                                    if (get_query_var('paged'))
                                    $args['page'] = intval(get_query_var('paged'));
                                    $content = framemarket_mp_list_global_products( $args );
                                    $content .= get_posts_nav_link();
                                    echo $content;
                                ?>
                        <div class="clear"></div>
                        </div>
    				<?php }  else {?>
    					<h1 class="post-title"><?php _e( 'Our products', TEMPLATE_DOMAIN ) ?></h1>
    						<div id="mp-product-grid">
    							<?php framemarket_grid_mp_list_products();?>
    							<div class="clear"></div>
    						</div>
    				<?php } ?>
    	<?php } else { ?>
    		<h1 class="post-title"><?php _e( 'Our products', TEMPLATE_DOMAIN ) ?></h1>
    			<div id="mp-product-grid">
    				<?php framemarket_grid_mp_list_products();?>
    				<div class="clear"></div>
    			</div>
    		<?php
    	} } else { get_template_part( 'content'); } ?>
    			<?php if($bp_existed == 'true') : ?>
    			<?php do_action( 'bp_after_blog_home' ) ?>
    			<?php endif; ?>
    </div>
    <?php get_sidebar(); ?>
    <?php get_footer() ?>

    Seriously, any advice you might have for troubleshooting this will be greatly appreciated.

  • virtuallymarj

    I have a question....

    I had to copy the gridmarket theme from the themes folder in Framemarket to make it show up for a single instance install. There seems to be a lot of bulky code related to checking for and handling a buddypress or multisite install and, in this case, that is irrelevant.

    In order to avoid my having to look through every script in GridMarket, can you quickly list the dependencies of that theme with Framemarket?

  • virtuallymarj

    Hey Phil,

    I'm really not enthusiastic about having to start all over again on this theme design and I was really hoping you'd have some ideas for me that would point me in the right direction.

    I've spent the entire day looking at every element of the style sheet with a fine tooth comb and it just is not leaping off the screen at me.

    I found a thread on WordPress.org that suggested it could have something to do with permanlinks so I resaved them to no avail. I know that rewrite is enabled on my server. I just checked .htaccess.

    I haven't changed any code in the loop. What could cause the comment form to open as if it needed to be canceled?

    Link: http://mildlymystified.com/holstar/devsite/

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.