Comments + Google Login Not Working

For some reason, when I try to comment via Google, the pop up box just takes me to my Google account page with nowhere to login to the app.

  • Adam Czajczyk
    • Support Gorilla

    Hello angeljs,

    I hope you’re well today and thank you for your question!

    There are two ways to connect to Google API: the “legacy” one and the “Google+ auth”. However, due to some changes introduced by Google to their policy in order to use Google+ you will want to create an App (that’d be the “Google+ Auth” method). Here’s a short guide on how to do this:

    In case of Google+ you need to setup your own application (Google+ Auth) instead of the Legacy authentication method (please see the screen).

    Follow instructions provided in Dashboard -> Settings -> Comments plus:

    – Create your application

    – Click Create Project button

    – In the left sidebar, select APIs & auth.

    – Find the Google+ API service and set its status to ON.

    – In the sidebar, select Credentials, then in the OAuth section of the page, select Create New Client ID.

    – In the Application type section of the dialog, select Web application.

    – In the Authorized JavaScript origins field, enter the origin for your app. You can enter multiple origins to allow for your app to run on different protocols, domains, or subdomains.

    – In the Authorized redirect URI field, delete the default value.

    – Select Create Client ID.

    – Copy the value of the field labeled Client ID, and enter it in the Comments+ Google settings fields

    In the step ” In the Authorized JavaScript origins field, enter the origin for your app. You can enter multiple origins to allow for your app to run on different protocols, domains, or subdomains.” you will put your domain name with the “https:”.

    When you copy your Client ID be sure there is no any additional spaces before and after the ID – spaces will cause error.

    This is described on your “Settings -> Comments Plus” page – > “Google App info, Google+ auth” section.

    Let me know please if it helped!

    Best regards,

    Adam

  • Predrag Dubajic
    • Support

    Hi angeljs,

    I tested your site now with my own Google App connected to your site and it still isn’t working so it looks like something is blocking G+ to communicate with your site.

    Could you please run a basic troubleshooting by disabling your other plugins and switching to default wp theme and see if the comments are working after that?

    Best regards,

    Predrag

  • angeljs
    • The Crimson Coder

    There actually appears to be a problem with using this plugin with Internet Explorer. The Google button doesn’t show in IE, and when the Twitter account connects, the Twitter window stays open with the comments page in that. I have to close down the Twitter window and refresh the WP page to post via Twitter.

  • Adam Czajczyk
    • Support Gorilla

    Hello angeljs!

    I have tested your site again with Internet Explorer 11 and recent Firefox. The Twitter button shows up in both cases but it doesn’t work for me with both browsers. The Google button doesn’t even show up in both.

    Most recent interaction in this thread was a year ago. That’s long enough for big services such as Google and Twitter to change their API/dev console settings etc so it might be necessary to regenerate/setup new apps for both these services. I’m saying this because testing with IE on my site did let me use the plugin with no issues such as on yours.

    I would start with:

    1. creating a whole new app for Google and configuring it in plugin

    2. in Twitter app (at apps.twitter.com) page use “Regenerate Consumer Key and Secret” button to create new Consumer Secret and Key and make sure that during the process the “Allow Twitter sign-in” option is enabloed;

    Once you update plugin’s settings with new apps’ credentials, clear all the caches please and give it another try.

    Kind regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.