Comments not showing up custom post type

The ability to have comments appear is clicked in the 'supports' section of the post type but the comments box is not appearing on the page.

Oddly enough one comment got through shortly after the page was published - not sure how that happened - its in the comments of Wordpress but its not showing up on the page.

http://www.cortjohnson.org/blog/doctor_blogs/me-and-dr-chia/

  • kevin_m__schafer
    • New Recruit

    Hi @CJ,

    When you go to your dashboard and view all posts, can you hover over your post title and then click on "Quick Edit?" See if the box is ticked for "Allow Comments." Also, at the same time, below the admin bar at the top of your screen you'll see a little tab for "Screen Options." If you click on this tab, a settings field will drop down. Make sure the little tick box is checked for "Comments."

    I hope this helps.

    Best,
    Kevin

  • CJ
    • Site Builder, Child of Zeus

    Thanks

    Checking All posts and checking on 'quick edit' shows that comments are enabled for the posts. The custom post type doesn't show up in 'all posts' but checking on quick edit in the custom post type shows that comments are enabled there as well. I'd already checked screen options for the custom type post and comments are enabled in that as well.

  • kevin_m__schafer
    • New Recruit

    Hello @CJ,

    I have thought of something to try. Could you please activate the default theme in your installation to see if the comments then show up below a post?

    Before you activate another theme, Twenty Eleven or Twenty Twelve, write down what widgets you have in your sidebar and where they are locatd. They may change positions when you switch between the themes.

    The fact that your comments aren't appearing could be the result of a feature in your theme. I'm very curious to know as to whether or not comments will appear with a default WordPress theme. This will prove to be a very good step in troubleshooting.

    I hope this helps.

    Best,
    Kevin

  • CJ
    • Site Builder, Child of Zeus

    Thanks Kevin,

    I don't know how you dug that up but that was the problem; the comments reappeared after switching to the default theme.

    It may be that I use either custom post types or that theme (Ithemes)....rather disappointing!

  • kevin_m__schafer
    • New Recruit

    Hi @CJ,

    I'm glad we somewhat pinpointed the problem, but it's too bad that it does exist. You may have free support with iThemes. Perhaps the best thing to do at this time is to tell them of this issue. Perhaps they will have a quick solution.

    Please post back should you have anymore questions.

    Best,
    Kevin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.