Comments Plus Breaks Gravity Forms

Hi there, pretty much as the title says, I have a form on one of my blogs and a user reported the form to be missing, I suspected the culprit might be a recently enabled plugin so I disabled comments plus and bingo, gravity forms was back.

Here was the post in question:

http://drummersdatabase.com/blog/2012/09/ad-snare-competition-voting-round-3/#comment-87

Any ideas what might have happened?

Thanks folks!

  • Vladislav
    • Dead Eye Dev

    Hello,

    Thanks for sharing the link – I’m sorry if I’m asking an obvious question, but were you able to confirm the issue yourself? I’m asking because I was also unable to see the form until I registered at your site, so perhaps this could be the case with this user too. If what I just said is all wrong, would it be possible for you to temporarily switch the plugin back on so I can check out what’s going on myself?

  • davejmason
    • Site Builder, Child of Zeus

    Hi Vlad, the form is set only to appear to logged in users do no it won’t show to regular visitors, however it would at least show a message saying “you must be logged in to see the form” or similar.

    Instead the form disappears completely, whether you’re logged in or logged out.

    I could temporarily enable it again but only as long as necessary as I have a very important vote happening on the site and can’t afford for the form to go down. I could create you an admin account so you could enable it only as long as you needed to to take a look?

    Thanks, D

  • Vladislav
    • Dead Eye Dev

    Hello,

    I understand the situation with the voting going on right now. If you could please set up an admin account as you suggested, so I can very briefly toggle the plugin on/off and investigate the conflict, that would be great. If you do so, can you please send the credentials to me via our contact form ( https://premium.wpmudev.org/contact/ )? Please, mark it for my attention in the subject, and please include a link to this thread in the message body.

  • Vladislav
    • Dead Eye Dev

    Hello,

    Thank you very much for this, I have been able to pinpoint the conflict – fortunately, it seems to be easily fixed by allowing the Comments Plus plugin to load its Twitter dependencies in plugin settings. There’s an underlying issue that caused this and I’m working on an update to fix it, but just toggling this setting for now should get the form showing and working alongside Comments Plus.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.