Comments Plus messing with Headway Leafs

I installed Comments Plus, and it looks great on the post pages. However, it's causing some conflict with leafs.

Here's what my homepage generally looks like: http://screencast.com/t/jy9dTIyxwEs
With Comments Plus enabled: http://screencast.com/t/VIWbRL912r6
Site URL: http://goldmedalbodies.com (currently plugin is inactive)

The affected leaf is a html/php leaf containing a java embed code. With the plugin active, it can't be selected/moved/resized in the visual editor. Everything else gets shifted below it.

I'm not sure if the conflict in in the theme files or if it has something to do with the script.

  • DavidM
    • DEV MAN’s Mascot

    Hi rocksupreme and first off, welcome to WPMU DEV!

    I actually use Headway pretty extensively myself and am trying a few things with this currently.

    Could you let me know what hooks you're tying into here? I'm assuming headway_before_comments and headway_after_comments?

    Also, is the comments section appearing as it should on posts where it should appear, with the plugin active?

    -David

  • rocksupreme
    • New Recruit

    Hey David,

    I used the headway_before_comment_form and headway_after_comments hooks. If you use headway_before_comments, the login selection is above the actual comments and separate from the form.

    Post and Page comments appear as desired. Pages with lots of leafs are having error with non-content leafs.

  • DavidM
    • DEV MAN’s Mascot

    Thanks for confirming that, just wanted to be sure we've got the same settings there. In the Visual Editor, for pages other than your main page with the java embed, are you still unable to move Leafs around?

    If so, I think there's likely a plugin conflict involved, at which point it'd be best to go through deactivating plugins one by one to see where that conflict might be.

    I actually just had to do the same while testing this, though there wasn't a conflict with Comments Plus, just a general conflict another plugin was causing.

    Could you let me know if that's the case?

    -David

  • rocksupreme
    • New Recruit

    OK, so I played around and set this up on a test site.

    Here's the screen cap of the problem in progress:
    http://screencast.com/t/uHIxMAA1qct

    It would be great if this plugin could be used in a location that makes sense for posts with lots of comments or on pages where comments are often turned off. As it is, the plugin is conflicting (apparently) with the closure of the leaf, which affects the next leaf on the page.

  • Philip John
    • DEV MAN’s Apprentice

    Hiya,

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thanks!
    Phil

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.