Comments Won't Turn On

It does not matter how the discussion settings are configured, I cannot turn comments on at any network blogs. At first I thought the problem could be with Ultimate facebook overriding the settings but even with Ultimate FB deactivated the problem is still apparent.

Something somewhere must be over-riding the settings because I cannot turn comments on at any network blogs. I've tried deactivating the network activated plugins one by one and still a comment box will not appear on any post of any networked site.

Anyone any ideas?

  • Timothy
    • Chief Pigeon

    Hey There.

    Did they appear before in this theme? Have you tried with the Twenty Eleven theme? Just to make sure it is not a theme issue.

    To deactivate all plugins quickly, just rename the plugin directory and then load your site to see how that works.

    This deactivates all plugins and network plugins.

    You might also need to rename your /mu-plugins/ folder if you have one.

    So change:

    /wp-content/plugins/

    To something like:

    /wp-content/something-plugins/

    And:

    /wp-content/mu-something-plugins//

    To:

    /wp-content/mu-something-plugins/

    This will ensure absolutely all plugins are deactivated on your site whilst you test again.

    You can rename them back after you test the issue again.

    Let us know how that goes.

    Take care.

  • ArticleCK
    • Flash Drive

    I think I have fixed it. The problem was with cets_blog_defaults.php (new blog defaults) which I
    had installed in the mu-plugins folder. (forgot to deactivate mu-plugins).

    I removed that, now comments can be turned on.

    Thanks for your help.

  • Timothy
    • Chief Pigeon

    Excellent to see its now sorted, I've not used that plugin in a while now. Good to see its still going.

    If you wanted the plugin then when installed, under:

    Admin --> Network Admin --> Settings --> New Blog Defaults

    You should be able to change the default behaviour for discussions.

    I don't however see anything in there forums about it killing the comments totally regardless of settings unless I missed it :disappointed:

    If no matter what you did the comments didn't work then maybe its a bug with the plugin or a conflict somewhere.

    Anyway, I'm glad its now supported for you. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.