Compatibility Between WooCommerce Theme and WPMUDEV Plugins

Hello,
I heard about some issues between WooCommerce and WPMUDEV themes. I'm already using a WooCommerce compatible theme so that is no problem. What I am wondering is if you know of any issues between WPMUDEV plugins and WooCommerce compatible themes?

I just want to know if this is something that I need to watch out for in the future just in case.

Thank you very much for you advice