Compatibility issue with next NextGEN Gallery

I noticed that on WP 4.0 combined with NextGEN Gallery 2.0.66.29 the newsletter plugin triggers two js errors on the newsletter template editor.

I disabled all other plugins, so it has to be a conflict with NextGEN Gallery.

TypeError: tinyMCE.activeEditor is null
http://mydomain.com/wp-admin/customize.php?wp_customize=on&theme=iletter&newsletter_id=13&return=admin.php%3Fpage%3Dnewsletters
Line 113

ReferenceError: jQuery is not defined
http://mydomain.com/wp-admin/customize.php?wp_customize=on&theme=iletter&newsletter_id=13&return=admin.php%3Fpage%3Dnewsletters
Line 240

Because of the errors the auto updating of the new images in the preview breaks. Any ideas on how to prevent the js errors?

  • Vaughan
    • Support/SLS MockingJay

    Hi @tijmensmit,

    Hope you're well?

    I can confirm the JQuery is not definied error in my console, however i'm not seeing the first error regarding tinyMCE.

    I can confirm the same issue though, but i'm unsure of which plugin is causing it, whether it's an issue with our plugin or nextgen.

    Let me just ask one of our developers to see if he can take a look into this and confirm whether the issue is with our plugin or nextgen.

    Thanks for the report, hopefully we can fix this.

    Thanks

  • Jose
    • Bruno Diaz

    Hello @tijmensmit,

    Hope you are doing great today,

    I'm following up in this thread and just ran some tests without being able to reproduce the error.

    I'm using the following versions:
    - WP 4.1
    - NextGen Gallery 2.0.66.37
    - E-Newsletter 2.7.1.1

    Are you still experiencing thos error? Did you try using a different theme?

    Please advise.

    Thanks,
    Jose

  • Andy
    • New Recruit

    Hello,

    I have this exact same issue, even after all these years.

    Here is my current setup, nothing else installed, default theme:
    - WP 4.9.2
    - NextGEN Gallery 2.2.33
    - E-Newsletter 2.7.4.3

    When you click on Create Newsletter and the Customizer starts, there's a JS error saying 'jQuery is not defined' and all kinds of things don't work anymore.

    I have tried toggling NextGen's rather odd NGG_FIX_JQUERY but it still doesn't work.

    Any suggestions?
    /Andy

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.