Compatibility: Multisite 3.4.1, BuddyPress 1.5.6

Does this mean it is not single install compatible?

Compatibility
Multisite 3.4.1
BuddyPress 1.5.6

Thank You!