Compatibility of Event+ 1.5.3 to WP 3.4.2 and BP 1.6.1

I have Event+ 1.4.4 installed and am struggling getting the fpe to happen from the groups page insted of the member page. Also the event creation is not being tracked as a "groups" component in the activity table and therefore group members don't get notified of it. Would upgrading help? If so, is Event+ 1.5.3 compatible with WP 3.4.2 and BP 1.6.1? (The plugin description only says "Compatible WP 3.5, BP 1.6.2" so I was wondering if it meant "up to WP 3.5 and BP 1.6.2"
Thanks
Marie