Compatibility with 3rd party plugin

I want to use Upfront with a plugin named WpClubManager. They have a doc on how to add hooks for theme compatibility, but I do not understand how I can use that with the Upfront themes (which are fantastic).
Can you take a look and let me know if this is trivial or too complex?
https://wpclubmanager.com/docs/themeing/