Compatibility with WordPress as a git submodule

Hello,

I'm setting up a MU install using WordPress as a git submodule and I was wondering if your plugins, especially the domain mapping plugin, is compatible when WordPress is outside the 'root'.
I'm using the file/folder structure of WP-Deploy https://github.com/Mixd/wp-deploy

-Brian