Compression - Failure

Hi,

I get the error

"gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us."

and I'm unsure how to fix it.

Thanks

Stuart

  • Sohag Ronjon Dey

    Hi StuartM,

    Hope you are doing well today!

    Can you ask your host to make sure you have the mod_deflate or ngx_http_gzip_module enabled? It will depend what your server is running, but they will know

    That is the most common issue here that the required module is simply not enabled.

    Something you can do while waiting to hear back from them or before you contact them is a basic theme/plugin conflict test? To perform it try to temporarily deactivate all plugins except Hummingbird and WPMU DEV Dashboar. Then try to run the compression again. If worked, then enable the plugins one at a time and try to run the compression after each activation to see if the error generates. In this way we will be able to find out the conflicting plugin if there is any.

    Please visit the following article to follow the steps of conflict test (you may need to scroll the page down a little):

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If your host replies back saying that the module is already enabled and your plugin/theme conflict test doesn't provide any results then please send us your credentials through our contact form which will also help us to investigate this further,

    https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -ftp credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please DO NOT post the credentials here as this is a public forum, also would you mind me doing some basic troubleshooting such as temporary deactivating all plugins?

    Please let me know.

    Cheers,
    Sohag