Configuring snapshot pro offsite GoogleDrive backup with authorized destination

I need to configure offsite backups using the Google Drive destination that I have had authorized. The first backup ran last night, but used local server storage; even though the backup job is set to use the Google Drive destination.
Can you help me to configure the settings properly? Is there a way to verify the authorized destination works with my settings for a particular snapshot, prior to the run time? In other words, can I test the write to the destination when setting up the snapshot backup job?

  • Jude
    • DEV MAN

    Hey HostRVA

    Hope all is well with you !

    The first backup ran last night, but used local server storage; even though the backup job is set to use the Google Drive destination.

    Did the backup get saved on Google Drive ? There is no way to save the file on google drive without creating a local backup first.

    Is there a way to verify the authorized destination works with my settings for a particular snapshot, prior to the run time? In other words, can I test the write to the destination when setting up the snapshot backup job?

    Yes this should be possible with the run now option. Take a look at my screenshot on how to trigger it.

    Cheers
    Jude

  • HostRVA
    • New Recruit

    Jude,

    The backup saved to the localhost, not to the GoogleDrive. Something isn't right here and I'm just not sure what it is. If I need to change a setting or what.. I did "run now" and it runs fine on the localhost, just no backup files appear inside GoogleDrive still.

  • Luís
    • Support

    Hi HostRVA ,

    Hope you're doing well today!

    I tried to make a backup only with the database and it worked properly and was sent to the destination, as you can check in the Snapshot list.

    However, I tried to create a new one to include the files (themes, plugins, etc) but I got an error.

    The most commom issue is related to "memory limit" and "max execution time" variables. Can you try increase them? I think this article may help you:

    https://premium.wpmudev.org/blog/increase-memory-limit/

    Try increase the memory limit to "512M" and "max execution time" to "300", it should be enough to test it again.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.