Confirm Appointment screen displays wrong currency

I am on your trial and have installed Appointments+ together with MarketPlace in order to use a South African payment gateway. Everything works fine, except on the Confirm Appointment screen it limits me to ONLY PayPal currencies. Can that be changed?

  • Ivan

    Hi Morne !

    I changed the currency on your site. If you want to do it on another site - try adding the following snippet in a MU plugin ( more info about MU plugins is here )

    <?php
    function wpmu_app_add_zar_currency( $currencies ) {
        $currencies['ZAR'] = __('ZAR - South African Rand', 'appointments');
        return $currencies;
    }
    add_filter( 'app-template-currencies', 'wpmu_app_add_zar_currency' );
    function wpmu_app_add_zar_currency_code( $codes ) {
        $codes['ZAR'] = 'ZAR';
        return $codes;
    }
    add_filter( 'app-template-currency_symbols', 'wpmu_app_add_zar_currency_code' );

    Then you can see this currency into WP Dashboard -> Appointments -> Settings -> General -> Payments -> Currency list. Please, select it and save this change.

    Best,
    Ivan.