Confirmation email is not delivered

Hi,

I have a problem with sending confirmation emails to the users.

The confirmation email is sent immediately after the booking if i enable automatic confirmation in the settings.

But if i set confirmation emails to be sent once the service provider confirms the appointment using the admin panel, the emails are not delivered to the user for some reason.

I have hosted my website in bluehost. Do you have any idea about what is wrong here?

  • vinoth

    Hi,

    There are no erros in the logs and i have enabled "Send Notification to admin if confirmation is required" option as well.

    Now, i could able to receive the email if i click the option to send email as shown in the attached screenshot (confirm.png) when ever i am confirming the appointment.

    I expect that to happen automatically when ever i am confirming the appointments from the main table as shown in the screenshot (appointments.png).

    Is it the intended behavior? I do agree that normally we cannot confirm an appointment without checking the details :slight_smile:

  • Alexander

    Hi @vinoth,

    I'm sorry for the delay here. The user should get a confirmation email when the appointment is confirmed by the service provider.

    I've just done some testing for this issue on a lab site and I think this could be a bug in the plugin. I've tried manually confirming a newly booked appointment in the dashboard, but I'm not getting a notification.

    I'll bring this to the attention of the plugin developer.

    Best regards,

  • jimesten

    I'm seeing similar (and I think even more serious problems..).

    1. auto confirm not working at all .. a no fee appointment is not auto confirmed, nor does ANY email notification go out though both things should happen.

    2. If I manually confirm, a reminder email does out, but only to the client. I've still gotten ZERO emails to either the service provider address or the admin address.

    ... so, to echo mmedia's comment... quite a problem that client's don't get a confirmation, but made worse if the provider doesn't know that an appointment has even been requested!

    thanks,

    Jim

  • parker_mason

    Jim,

    I was having this issue as well. I definitely think there is an issue in the code somewhere. None of these solutions are perfect, but they might be a decent temporary workaround. A few things to check:

    First, check the spam folder in your email. I know that Gmail for one has been recognizing Appointments+ emails as spam and I have had to go in and specifically say that they were from a trusted sender.

    Second, if you are testing the plugin with an appointment from the exact same email address as the "Admin" email on your Wordpress site, I've found that the email doesn't send for some reason.

    Third, if your admin / service provider is using an email address on the same domain as the website, try it with a different email. Mine started working after I set the emails to go to a different domain. You can check the log to see if the plugin thinks that it is sending out the emails.

  • jimesten

    I changed up the reminder interval and that seemed to be enough to get the reminders to flow as well as the reminder to the provider address. So .. that's a good start. I'm way on top of the GMail spam .. I'm a level 3/4 support tech by day and have been fighting lost email battles for the better part of the last 5 weeks. At one point early this week, GMail was running about 23% false positives to the spam folder.

    Bigger concern now is the auto confirm of appointments that are zero cost. They get stored, but as pending even though it would seem that with auto confirm set to Yes, they should do exactly that and notify the provider.

    Oh, and nothing in the logs that I didn't actually receive....

    Thanks for the tips.

    peace,

    Jim

  • Vladislav

    Hello,

    Indeed, when changing the appointment status, the confirmation email won't be re-sent unless the "(Re)send confirmation email" field has been checked. This is in order to reduce the amount of unwanted outgoing emails, since the appointment status can be changed arbitrary number of times.

    @jimesten and @parker_mason your issue is different. In a payment-ready environment, the default plugin behavior is to not auto-confirm the new appointments unless they're paid for. This happens for a reason - the "confirmed" appointments are counted internally as a sure thing unless explicitly told otherwise by changing the status, but an appointment with a price that hasn't yet been paid for is not really that.

    Also, this logic is also applied to your free ($0) appointments. If you have such appointments set up, I agree that this doesn't make much sense, and so it has been fixed in v1.4 - however, the described behavior has been kept as default for backwards compatibility reasons. To enable auto-confirming of your $0 appointments in a paid environment, can you please add this line to your wp-config.php:

    define('APP_CONFIRMATION_ALLOW_FREE_AUTOCONFIRM', true);

    Can you please give this a go and see if it helps?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.