Conflict between eNewsletter and bbpress

I tried to activate both PHP mail and wp mail in eNewsletter on the settings page. The following error came through.

Warning: in_array() expects parameter 2 to be array, null given in /home/rvhobo7663/public_html/wp-content/plugins/bbpress/includes/common/functions.php on line 1446

Warning: Cannot modify header information - headers already sent by (output started at /home/rvhobo7663/public_html/wp-content/plugins/bbpress/includes/common/functions.php:1446) in /home/rvhobo7663/public_html/wp-includes/pluggable.php on line 1167

  • Rupok
    • Support Ninja

    Hi jetiii, hope you had a wonderful day.

    Are these warnings gone when you deactivate E-Newsletter plguin?

    Both warnings are saying that you have bbpress has issues in it's file. So can you please ask in their support forum and let us know what they say about this? In my understanding, we don't have much to do unless they fix those issues. But if there is anything we can do from out end, please let us know. We will be glad to assist further.

    Have a nice day. Cheers!
    Rupok

  • jetiii
    • Site Builder, Child of Zeus

    These warnings ONLY show up when I try to create a new newsletter. However, the newsletter is created, although I am not sure if it is complete. I will investigate.

    The code is:

    if ( in_array( 'post_parent__in', $wp->private_query_vars ) )
    return $where;

    How is a buddy press function being called? Are you hooking into buddy press with the newsletter?

    BuddyPress is working fine with no issues in the support website. Again, this only happens when I create a new newsletter.

    After 39 years as a Senior Computer Scientist, this looks to me as 1) a naming conflict or 2) a BuddyPress linking problem. This, in my opinion, is not in BuddyPress, but in your code. I may be wrong as this is not writing a Parallel OS, must be more complicated. LOL

    Jesse

  • jetiii
    • Site Builder, Child of Zeus

    Hi again,

    I setup a new website newsletters.rvhobo.net. I used x-themes and added eNewsletters. While they went to fast for me to see, there were conflicts. Additionally, I got a warning I was trying to edit a page I did not have rights to.

    I will try with one of the upfront themes.

    You have access to the site.

    Jesse
    Jesse

  • Rupok
    • Support Ninja

    Hi jetiii, hope you had a wonderful day.

    I tried to regenerate the issue on my test site but I could not. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • jetiii
    • Site Builder, Child of Zeus

    Hi Rupok,

    I did open the website for you. It has been open but may have recently run-out as no-one went there for this or the other open issue I have. I will check the website (WordPress MU) and see if it remains open or open it if required. Please get this done as I don't like leaving the site open. rvhobo.net.

    Thanks,

    Jesse

  • Rupok
    • Support Ninja

    Hi Jesse, hope you had a wonderful day.

    Thanks for granting Support Access. I could login successfully. But you have both bbPress and e-Newsletter network deactivated and I'm not sure which subsite to check for the issue.

    You said "I setup a new website newsletters.rvhobo.net" so I went to newsletters.rvhobo.net but it's taking me to new site registration page and showing me this:
    The site you were looking for, http://newsletters.rvhobo.net/, does not exist.

    Am I missing something? Can you please specify on which subsite I can check this? If it's not activated in any site right now, do you want us to create a test subsite, enable these two plugins there and investigate the issue?

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • jetiii
    • Site Builder, Child of Zeus

    A plain-jane website with th edefault theme has been setup at newsletters.rvhobo.net. It tells me that I'm cheating when I try to edit a page. Strange as I am the Supper Admin.

    When creating a newsletter it reports a couple of errors that go by to fast to see what they are.

    The site is active. I will extend the time period.

    Jesse

  • jetiii
    • Site Builder, Child of Zeus

    Update. I wrote a newsletter. I went to save it, it brought up the "Cheaten Uh" and lost about an hours work. I know there have been others that had this error (WordPress) but it is ONLY happening with your eNewsletter plugin.

    Jesse

  • Kasia Swiderska
    • Support nomad

    Hello Jesse,

    This appears to be a conflict with the W3TC plugin. It has come up a handful of times over the past few years and looks to only happen with a certain W3TC config.

    Our developer made a response on the matter here: https://premium.wpmudev.org/forums/topic/enewsletter-has-incompatibilities-with-w3-total-cache#post-591501

    We weren't able to find exactly which setting this relates too, if it even is a setting, it could be a combination between server and W3 config. If you deactivate W3TC while editing your newsletters then it should work fine. If you do happen to notice any connections between settings and when it happens then please do let us know and we'll investigate further.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.