Conflict or setup conflict with Native Articles Plugin Feed

Hello,

I am on trial and would like to signup. So far only problem i have is that for some reason the Facebook Instant articles feed is not working

It was working before and during the setup fo WPMU plugins so definitely its an issue that has come up.

Could you guys kindly check out and advise?

Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello @Islim,

    I have checked your site and I think it's a caching problem.

    Your site seems to be a bit "over-optimized". Currently you have Autoptimize plugin installed with most optimization options enabled, Optimize.io with some optimization options and Hummingibird.

    Most tools of these plugins are redundant. For now, I have disabled Hummingbird's Page Cache and after clearing up Autoptimize cache, the FB Instant Articles feed (https://am......com/feed/facebook-instant-articles/) seems to be recreated.

    I left the Page Cache in Hummingibird disabled on your site but I'd recommend actually doing this:

    - disabling all Cache options and minification feature in Hummingibird
    - disabling Autoptimize and OPtimize.io entirely
    - then enabling Minification in Hummingibird again and fine-tuning it if necessary
    - then enabling caches (including Page Cache) in Hummingibird back.

    If after that FB articles feed is still not working, we could troubleshoot the issue. In a long run, however, that should let you avoid other possible issues caused by "over-optimization" of the site.

    Best regards,
    Adam

  • woushu
    • WPMU DEV Initiate

    Am very new to this and only reason am on trial is cos i need super great speeds. Am on a VPS so resources not an issue. Could you do these settings for me kindly, deactive what you need and setup what you need then i can apply the same to other 2 sites i want on board? If it works out, great, am in.

    Thank you so much for the quick response.

  • woushu
    • WPMU DEV Initiate

    @Czajczyk Hi

    Unfortunately i havent been able to get it right with the settings, speed and FIA feed.
    I am rolling back and uninstalling WPMU (i am on trial).
    If your team can have this done for me, i would be more than willing to sign up.

    Thanks for your time.

  • Predrag Dubajic
    • Support

    Hi Islim,

    Do you have FB Instant articles configured from the FB dev page here https://developers.facebook.com/docs/instant-articles/publishing/setup-rss-feed or you're using a plugin to display it?

    Can you tell me on which page we can see the feed so we can investigate this further?

    I tried your reccommendations on a diff site and it dropped in performance.

    When doing optimization wait some time for minification process to finish before checking the stats as the site will be showing lower score while minification is performing its initial run.

    Best regards,
    Predrag

  • woushu
    • WPMU DEV Initiate

    I am using a plugin for this.

    "Facebook Instant Articles for WordPress by OzTheGreat"

    You can check the feed output on my two sites connected to the account https://a.............com/wp-admin/admin.php?page=wpna_facebook

    and https://p...........ke/wp-admin/admin.php?page=wpna_facebook

    There is a setting in hummingbird that sort of makes Facebook blocked from accessing the feeds.

    I have redone the settings but still same issue

  • Adam Czajczyk
    • Support Gorilla

    Hello @islimrans!

    I have accessed the amr...... com site again (didn't make any changes there this time) and I admit I'm a bit confused.

    I understand that you made changes that I suggested but apart from the performance issue that you mentioned (which, I believe, we could still address but I think we should first deal with those Instant Articles), I see that the Instant Article Feed now doesn't seem to be working at all.

    What I mean is that when I left your site previously, the feed at https://amr....com/feed/facebook-instant-articles/ was showing articles and was up to date. Currently, it's showing pretty much nothing except the feed title.

    Clearing cache doesn't change it and I think this particular thing is something a bit more complex or unexpected than we both assumed. Did you make any other changes to the site configuration and/or especially FB instant articles feed plugin setup? Could you please also try disabling Hummingbird entirely temporarily and see if the feed shows up and if FB is able to access it?

    I can check it myself of course but I'd need an explicit permission from you to do any configuration changes on site that I might consider as necessary, first. It would also be good if you could confirm first that you do have a full backup of the site before I proceed, just in case something went unexpectedly wrong.

    Kind regards,
    Adam

  • woushu
    • WPMU DEV Initiate

    Hi Adam Czajczyk

    You have my permission to do any changes as you need. I have a backup no worries there. Please go ahead and make any changes you need. I really wanna sign up but it depends on only two things;
    1) Speed 2) Should work as before
    So help me out please.

    Thank you

  • Adam Czajczyk
    • Support Gorilla

    Hello Islim!

    Thank you for your response!

    I've made some changes with your site (including some experimenting with plugin settings) and the current status is:

    - I have left Hummingibird enabled with Asset Optimization (formerly called "Minification") configured as much as I could without breaking the site; it is possible that it might be tuned even more but I don't know the site that good to be able to do that - you'd need to try to move some JS/CSS scripts to the footer, after setting that for each single script checking the site if nothing breaks.

    - Instant Articles feed seems to be loading fine and is also excluded from cache, as well as RSS cache is disabled; additionally, Facebook crawler bots are excluded from cache at all

    - the site seems to be running/loading really fast, but I can't come much above the current performance score (though that's actually not a score of speed!).

    I have actually tested the site with PageSpeed with both my current configuration and with Hummingbird disabled totally but Autoptimize enabled and configured to "optimize pretty much everything possible" - the score was the same. I have noticed something additional that bothers me quite a lot - in fact, PageSpeed doesn't seem to pickup any changes made on site which is really strange. Usually, even if there's some server-side cache this happens but it takes couple of minutes to re-test and changes are applied. But that doesn't happen in this case. Whatever I set in Hummingbird it shows the same assets as needing optimization, actually even pointing to a wrong location. So, the question is - is there some additional caching on server? If so, how to clean it up, is it possible to make changes to its configuration (I don't mean disabling it, only making it less "permanent" and possible to easily clear up)?

    There are also 4 other things that would be really beneficial to the site performance:

    1. Increasing PHP time limit to 120-180 seconds (currently it's 30 and this may cause "clogged pipe" effect sometimes, slowing down the site)
    2. Increasing PHP max input vars to 3000 (similar problem as above)

    These two are actually even recommended by your theme's System Status (see "Jannah -> System Status" in your site's dashboard)

    3. Increasing WordPress default memory limit; currently site's running on 40M of memory only which is far less than the server allows for PHP and also definitely too low for a complex site. To increase that, add following line to the "wp-config.php" file of the site above the /* That's all, stop editing! */ line:

    define('WP_MEMORY_LIMIT', '256M');

    4. Switching PHP version to 7.x. Currently site's running on PHP 5.6.34 which is quite outdated. 7.x would not only boost preformance but also add up to stability and security of the site.

    Kind regards,
    Adam

  • woushu
    • WPMU DEV Initiate

    Hi Adam Czajczyk

    You been amazingly most helpful. I have followed your recommendations above and amazing. Thank you.

    I will also try follow up the settings you applied on this one and try apply the same on the other two. I will be more than glad to follow this up with how its gone. So far am excited. Thank you so much for looking into this.

  • Adam Czajczyk
    • Support Gorilla

    Hi @islimrans!

    On that second site, unfortunately I support access doesn't work for me. When I try to access front-end or /w-login.php page directly, they are both loading (though very slow) but since I'm not logged in, that's of no help :slight_frown:

    I'm guessing that you are able to access the back-end via /wp-admin right? Can you please go to the "WPMU DEV -> Support" page, revoke the support access and enable it again? Sometimes a "glitch" happens that makes support access not fully activated. Let me know when it's done and hopefully it will work for me this time.

    Kind regards,
    Adam

  • woushu
    • WPMU DEV Initiate

    Hi Adam Czajczyk

    I have. I contacted my host and there was a cache issue with Nginx and that's resolved. The php has also been updated. However my host says the site needs optimization, a lot of resources have to load...sorry, am not a developer.

    I hope you have access, kindly as i'd requested, if you could tweak and optimize as you need so it can work well with WPMU and give me great speeds?

    Thank you so much for the help

  • Predrag Dubajic
    • Support

    Hi Islim,

    I'm afraid that we still can't access your site to further check your settings :slight_frown:

    Could you send us your login details by using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below so we can access it that way:

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Islim,

    About http://www.c......a.com site, it seems your wp-config.php was a bit messed up, some things were misplaced so when I put everything in place I was able to save the Smush settings properly.

    Similar thing was happening on http://www.p..........ke as well, it should be working fine now.

    When adding stuff to wp-config.php make sure that all the code is added above /* That's all, stop editing! Happy blogging. */ line, adding things at the end of wp-config can cause all kinds of issues.

    Best regards,
    Predrag

  • woushu
    • WPMU DEV Initiate

    Hello

    I kept getting the 500 error after upgrading php on a........d.com even though has the same theme with p.......ke. I looked it up with my host and the issue was with hummingbird, and we disabled that. Could you look into this?

    Thank you

  • Predrag Dubajic
    • Support

    Hi woushu,

    I had a look at the a........d.com site and got 500 error when tried to access your login page.
    I checked your wp-config.php and you again had additional code added below /* That's all, stop editing! Happy blogging. */ line, note that nothing should be added below that line and only default wp-config.php code should be in there.

    After moving that code above the page I was able to access your site, however I was still getting 500 error on various pages on your site.
    I've enabled debug log but it wasn't created on your site so I was unable to find out what's causing this error.
    Can you ask your host for the server logs and what's showing the errors as they are clearly there even with Humminbird plugin not being installed anymore.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.