Conflict – Social Marketing/Woocommerce

I have found what I believe is a conflict between Social Marketing and Woocommerce.

I have had to deactivate Social Marketing until this is resolved because the conflict is damaging our to our online sales.

Here is the problem …

When Social Marketing is activated it breaks the form on the Woocommerce checkout page on our website.

Specifically, the COUNTRY and STATE/PROVINCE field stops working.

When Social Marketing is activated, if I change the country from Canada to the United States, the county changes but the STATE/PROVINCE field does not change. It stays populated with Canadian provinces.

I have tested this and have learned that is it acting exactly the same way on six of our ecommerce sites.

If someone could test and confirm independently, I would appreciate it.

I would like to be able to reactivate Social Marketing.

  • James Morris
    • WordPress Enthusiast

    Hello brentjohner,

    I hope you are well today.

    I’ve just tested this on my own dev server with the following configuration:

    WP Core:

    WordPress 4.7.1

    Plugins:

    WooCommerce 2.6.13

    Social Marketing 1.2.3

    Twenty Seventeen Theme 1.1

    WPMU Dev Dashboard

    PHP environment:

    PHP 5.6.29

    The following video shows the plugins installed and me walking through the checkout process. When selecting different countries (US/Canada), the state/province field updates correctly. Screencast: https://goo.gl/bO3epo

    I understand the sites you are having issues on are production sites and cannot be tested on. In order to determine if this conflict is with WooCommerce, or some other plugin on your site, would you please setup a staging site where we can perform some tests? If this is possible, would you please provide us access to one of these staging sites?

    Please visit the Contact page and complete the form with the following information:

    Subject: “Attn: James Morris”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Admin login:

    Admin username

    Admin password

    Login url

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    – FTP credentials

    host

    username

    password

    (and port if required)

    Best regards,

    James Morris

  • brentjohner
    • The Incredible Code Injector

    Hi James.

    I disabled CANVAS and activated Twenty Seventeen as suggested.

    The problem persists.

    When Social Marketing is activated, if I change the country from Canada to the United States, the country changes but the STATE/PROVINCE field does not change. It stays populated with Canadian provinces.

    When Social Marketing is deactivated, the STATE/PROVINCE field populated with US states as it is supposed to.

  • brentjohner
    • The Incredible Code Injector

    Hi James.

    I set up a test site at dev.racquetnetwork.com

    The only things on it are these:

    WordPress 4.7.2

    Social Marketing 1.2.3

    WooCommerce 2.6.13

    WP Defender 1.1.5

    WPMU DEV Dashboard 4.2.1

    Twenty Seventeen 1.1

    Results are same as above …

    When Social Marketing is activated, if I change the country from Canada to the United States, the country changes but the STATE/PROVINCE field does not change. It stays populated with Canadian provinces.

    When Social Marketing is deactivated, the STATE/PROVINCE field populated with US states as it is supposed to.

    When Social Marketing is activated, if I change the country from Canada to the United States, the country changes but the STATE/PROVINCE field does not change. It stays populated with Canadian provinces.

    When Social Marketing is deactivated, the STATE/PROVINCE field populated with US states as it is supposed to.

    I have opened the SUPPORT DOOR.

  • Ash
    • WordPress Hacker

    Hello brentjohner

    I can confirm the issue is related to SSL certificate. There are some request in social marketing plugin that throws content over HTTP even if the site is HTTPS, so those scripts do not work and generating js error, as a result the woocommerce js is not working.

    I am marking this as a bug and reporting to the developer, hopefully very soon the issue will be fixed. We appreciate your patience on this. And thanks for reporting the issue, sending some issues in your way.

    Have a good day!

    Cheers

    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.