Conflict with Domain Mapping and Jetpack Publicize?

So we're running in to an interesting situation here. We are running a pretty large multisite network - we have both Domain Mapping and Jetpack installed. We were having a lot of trouble getting Jetpack's Publicize module to work but we found that manually setting the server port to 443 made it work - so adding this to wp-config:

/** Use new port for jetpack HTTPS **/
/** $_SERVER['SERVER_PORT'] = 443; **/

This will allow publicize to work, however it breaks any site that is using domain mapping and doesn't have their own SSL certificate, as it seems to basically force SSL on the front end.

Anyone run in to this before or have any ideas?
Thanks

  • Nastia

    Hello @fanalejr

    I trust you are doing well today!

    however it breaks any site that is using domain mapping and doesn't have their own SSL certificate,

    Would you please let us know how exactly the site breakes?
    - Do you see any errors when this happens
    - The Domain Mapping is not mapping
    - Or you see the white screen of death

    Would you please grant support access from your Dashboard > WPMU DEV > Support so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please enable WordPress debugging and try to access domain mapped sites again:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    All the errors will be saved to a debug.log log file inside the /wp-content/ directory, attach the debug.log in this thread so we can have a closer look.

    Please advise,

    Kind Regards,
    Nastia

  • James

    Hey - thanks for the response - I'm sorry I wasn't more clear. This isn't necessarily a bug with your plugin, more a question on if you think what we're trying to do is possible. Basically adding that snippet of code to wp-config forces SSL - so any site using a mapped domain that does not have a cert gets the "This site is unsafe" warning. Without that snippet of code though, we seem to be unable to use all of jetpacks features, mainly the publicize module.

  • Tyler Postle

    Hey James,

    Hope you're doing well today. I haven't run into this issue myself before.

    Have you tried port 80 instead? That shouldn't force your frontend to https. You may want to ask Jetpack support as well to see if they have recommendations given your situation, I'm sure you wouldn't be the only one to run into the issue. You are the first case I have seen though.

    If using port 80 doesn't work then perhaps try asking your host what port would be best to use to avoid forcing https on the frontend, that is more of a system admin question as each host is generally setup a little different.

    Let us know what you hear back and if there is a way we can help further then of course we will :slight_smile:

    Another option would be getting a multi-domain SSL cert, but those can be expensive so hopefully we can get publicize working through another port or your host has a solution.

    Look forward to hearing back and hope you have a great weekend.

    Cheers,
    Tyler

  • David King

    We've long had problems with JetPack Publicize and Domain Mapping (aggravated by Varnish), though I never did get to the bottom of it.

    So I'm keen to hear if there are any solutions to this. Perhaps we can (apparently) force SSL as OP suggested just for JetPack's callbacks?

    It is possible that settings like forcing the original domain for wp-admin has an effect also, because that means the front-end domain will be different to the backend domain, and JetPack's callbacks probably don't follow redirects correctly.

  • Tyler Postle

    Hey David,

    Sorry for such a delay on replying here. I forced SSL on admin/login and frontend with DM's settings, which doesn't include the mapped domain and publicize still works for me. So perhaps that could be a way around this issue. Using solely DM's https forcing settings which won't apply to the mapped domain.

    I don't have Varnish on my server though so you may still experience issues on that end of things.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.