Confused about max upload size

I'm getting errors like:

big-email-cover.jpg exceeds the maximum upload size for this site.

Now, the site thinks that's 1MB, so it's clearly not a PHP.ini issue. My PHP.ini allows up to 32MB uploads. Any idea where this is controlled?

(Oh, and bizarrely, when I switched to the browser uploader, it'd take 2MB files. Go figure)

Thanks!

  • Timothy
    • Chief Pigeon

    Hey David.

    If your php.ini is set to allow larger uploads and you confirmed that then it is most likely plugin or WP related.

    If you are running WordPress as a multisite then checkout:

    /wp-admin/network/settings.php

    Admin --> Network Admin --> Network Settings

    You can then decide on the upload size as well as upload space. Screen attached.

    Hey surpassweb, the function there is pretty much setting it through PHP:

    http://php.net/manual/en/function.ini-set.php

    Changing the theme wouldn't retain those settings. The php.ini or htaccess options are better for site wide changes.

    Take care.

  • Timothy
    • Chief Pigeon

    Hey again.

    Is this on a specific plugin, or just WP in general?

    You could also double check the upload limits are being set by using the phpinfo() function

    <?php
    phpinfo();
    ?>

    You can create a php file and enter that, then upload it. Once done open it in your browser and you can see your php setup. Also check in sub directories to ensure settings are throughout (recursive) and not being overwritten or not changed somewhere.

    Thanks

  • Dean Kaus
    • The Bug Hunter

    The limit may actually be set by your hosting company. If you have a cpanel you can go into their help section and search for upload limits. I believe there are several variations of cpanels so the steps I had to take will be different that yours.

    There are also a few themes that limit the photo or video size that you can upload. In my case I use a plugin called Cool Video Gallery

    For Photos I use NextGen

    Hope this helps solve your problem

  • David
    • The Crimson Coder

    > made any further progress

    No, I haven't. I can't really tell where the limitation is coming from. I'm not running someone else's hosted environment. I'm running Turnkey Linux on my own machine, so I have control over the PHP.ini file. PHP.ini allows 32MB uploads, so that's not it. I also turned off the WP quota system, so there's no maximum size for the media library.

    What's weird is that this error occurs in the drag-n-drop interface, but not in the file-selector interface. That has me thinking that there's something about the drag-n-drop interface in 3.3.1 that limits uploads.

    Anyway, that's where I'm at. Because I could upload the few files I needed to for this project, it's not an urgent priority. But I'm a curious sort and I'd just like to know why it's behaving so quirkily (which may not actually be a word).

    Anyway, thanks for your help.

  • Dean Kaus
    • The Bug Hunter

    Hi @David
    What file size are you trying to upload?
    What theme are you using?
    Do you have a link to your site?

    I've run into this problem several times in the past for various clients. Even though my server settings are set properly and WP I believe still has some issues with files over 10mb. Some themes have a limit built into them and not all have them in an obvious place.

    Once I'd find the location that was limiting the size it seemed as if a couple of months later my client would call back and have the same problem. What happened was that they updated their theme and overwriting my code that fixed the problem.

    I started using NegtGen Gallery and that has resolved all of my issues. I haven't had a complaint or had since I installed it.

    Let me know if this works for you.

  • Dean Kaus
    • The Bug Hunter

    Hey @David, No Problem. Site is very interesting and in today's world I think you have to be a little pompous to be able to get anything done or be heard. If memory serves me I'm pretty sure that the problem was within the PHP.INI file.

    Try this, open your PHP.INI file, select all and copy. Then close and rename the PHP.INI file to PHP-BAK.INI
    Create a new Notepad file and ten past the original PHP.INI content here.
    Then find the following section's and make sure these are at least your minimum settings.

    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    max_execution_time = 30
    max_input_time = 60
    memory_limit = 32M

    Then change the following for minimum settings as listed
    ;;;;;;;;;;;;;;;;
    ; File Uploads ;
    ;;;;;;;;;;;;;;;;

    ; Whether to allow HTTP file uploads.
    file_uploads = On

    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    upload_tmp_dir = /home/photoman/domains/kausdj.com/tmp

    ; Maximum allowed size for uploaded files.
    upload_max_filesize = 20M

    Also Check under the Data Handling Section Check the following and adjust accordingly.

    ; Maximum size of POST data that PHP will accept.
    post_max_size = 20M

    NOTE! I had to increase mine to 20M Only due to the fact that I had large files on a private page that my printer could download. This number need's to be set to the maximum file size you'll be uploading.

    Save file as PHP.INI and see if that works. I was looking over some old notes and it seemed that when I had just edited and saved (replacing the original) the PHP.INI file for whatever reason it either didn't take the new settings or simply ignored them. After I edited the file in Notepad and renamed the old file everything started working.

    One last question I had was how large of files are you trying to upload and if they are huge, why do they need to be that big?

    I can give you some photo optimization techniques if you need some help there. Photography and Video is my actual full time job, albiet slow right now.

    My membership is expiring tomorrow but you can contact me via email at kausphoto@gmail.com as well.

    I'll return here as soon as my business picks back up...

  • David
    • The Crimson Coder

    Thanks, Dean. I'll look forward to your return.

    The pictures are huge (HUGE!) because they are print-ready JPEGs. There's about 8 of them off the press kit page. If you click in the 270-pixel wide versions, you'll get honking big ones. I often get print outlets who want a print-resolution image of me (which can be used to scare away their audience) and this is a quick and easy way to do it. If it became too much of a hassle, I'd throw them up on Dropbox or something, but this is easy and works.

  • Dean Kaus
    • The Bug Hunter

    No Problem @David

    Just another thought that may save you some time and hassle as well. Lately I've just uploaded the larger files via FTP to a password protected folder. (this way a competitor can't get their hands on my high quality images and alter them to make me look bad) At any rate it doesn't need to be password protected, either way you can set up a hyperlink or give them the direct link from your posted (smaller) photo and it will do the same thing.

    On another note, who's doing your printing? Most of the print houses now only want a maximum 4-6 meg file and they res it up on their end. Takes a lot less time for them to res up and render the photo locally than to render a large file and then rastorize for their print server.

    I actually had one of my photos that was used on the side of building ( I think it was something like 250 feet wide by 700 feet tall) When DC was putting in their bid for the 2012 Olympics. I only submitted a 16 mg file. Amazing what they can do these days.

    Have a good one...

  • Dean Kaus
    • The Bug Hunter

    I was checking out the page the other day once you had it live. Man a lot of information. I plan on checking out more of it when I get some free time.

    Not sure if I had mentioned it earlier but I solved the majority of my upload limit problems by using the NextGen gallery. This way when a theme or WP update came along I didn't have to go back and make any changes.

    Glad you're up and running!

    Have a great one.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.