Connect with Facebook just hangs

Hi,

We are using Ultimate Facebook for the Connect With Facebook button.

We have it in our Login form but it just hangs when we click it. It makes a call to FB, indicates it is loading and then just sits there. No javascript errors are holding it back, as far as I can tell.

Please advise, we are trying to push this site live and this is the only thing holding us back!

http://esportudo.com/tempaccess

Thank you

  • Patrick

    Hi there @tony_demarco

    Happy new year!

    I see 2 Facebook login buttons on that page and, accorf=ding to console in Chrome, they are definitely conflicting (screenshot).

    Is one of them generated by your theme, or perhaps another plugin?

    Please try disabling that 2nd button that appears beside the grey login button. The one directly beneath the password field is the one generated by the Ultimate Facebook plugin

  • tony_demarco

    Hi,

    I disabled almost all plugins (except the ones critical to the site / page working) and reverted to the Twenty Twelve theme and it still is not working. I also updated every plugin we are using to the latest version

    I have also gone through my JS code and removed / fixed the only pieces that were throwing errors in the console. The only remaining errors are "Failed to load resource: net::ERR_CACHE_MISS" from the Facebook JS calls.

    Not sure if it is helpful, but the page is made with the Parallax Gravity plugin

  • Predrag Dubajic

    Hey Tony,

    Can you send us your FTP login credentials so we can further investigate this?

    You can send us your details using our contact form and this template:

    Subject: "Attn: Predrag Dubajic"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Best regards,
    Predrag

  • Ash

    Hello @tony_demarco

    I have tried to check your site, but the FTP you provided didn't work for me.

    I can see you have updated your wordpress into the latest, but you need to upgrade your network too. You will see a notice at the top of your admin panel "Thank you for Updating! Please visit the Upgrade Network page to update all your sites." - just click on upgrade network.

    Now about issue, I have deactivated Gravity Landing Page builder, Social Gallery and Social Gallery : Mobile plugins. Then I went to wp-login.php (as landing page is lost when builder was disabled) and successfully logged in. You can check the username called "bpp_grt".

    You can try by deactivating those plugins, but make sure you delete cache after deactivating plugins.

    So, this is a conflict with those plugins. I would suggest in this case to use the login form in a different or dedicated login page where you don't have gravity page builder.

    Please let us know how it goes.

    Cheers
    Ash

  • tony_demarco

    Hi,

    Sorry for the delayed reply, very busy week last week.

    The FTP needed to be set as "Active" for FTP mode, not setting it to Active does not allow you to connect.

    I have upgraded the network as you mentioned

    Yes, the login button does work on other "normal" login pages, but the client is really itching to have it work on this page. I've tried pushing them back on this and to go with an alternate page for login, but it is apparently "a requirement" so I am going to keep trying to debug the issue.

    IS there any more advice that can be given here? Is there something that anyone has seen in the past that would cause a conflict such as this one?

    Thank you

  • Ash

    Hello @tony_demarco

    I hope you are well today.

    IS there any more advice that can be given here? Is there something that anyone has seen in the past that would cause a conflict such as this one?

    UF plugins connects with facebook via javascript code. The nature of javascript is, if any error occurs in any line, after that line nothing will work.

    So, if any plguin causes any javascript error that comes before UF plugin, then the code of UF won't work.

    You really need to troubleshoot by deactivating other plugins one by one to check which one is causing problem in front end page.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.