Connection to S3

I'm trying to connect to our S3 bucket but it is just hanging. I know the credentials work as I use them for other connections?

  • Paul
    • The Green Incsub

    @nichola_musgrove3, Need to give more details. I'm assuming you are on the AWS Destination setup screen. You have entered your credentials. Are you selecting the bucket button? Or testing the connection?

    Where in the world are you? This has an impact on what server you connect to. You should see the dropdown.

    Have you tried SSL and non-SSL connections? Depending on your server SSL may not be supported.

  • nichola_musgrove3
    • WPMU DEV Initiate

    Hi,

    Quick question if S3 is set as a destination then I presume the zip's are stored there? In my bucket it is collecting connection test files which say 'WPMU DEV Snapshot Test connection file.'. But there is no zip file?

    Within wordpress I can download the zip but where is it coming from. Maybe it's because its a Friday afternoon GMT, but I'm baffled, am I missing something?

    Thanks,
    Nichola

  • Paul
    • The Green Incsub

    @Nichola, I'll look into the test destination files. Those should automatically be removed when testing the connection.

    As for the download those are coming from your server. When you setup Snapshot to send files to the remote destination you are really telling it to send the copy. The main file still reside on your local server. This is what on the 'When to Archive' section on the snapshot item there is an input field 'Maximum number of local archives' that lets you control the local files on your server. If you have disk space concerns then set thsi to 2-3. This means as new archives are added the older ones will be automatically removed.

    At the moment Snapshot does not manage the remote destination file. Meaning this is something you currently have to manage outside of Snapshot. But this is coming. Along with the ability to restore from a remote destination archive.

  • nichola_musgrove3
    • WPMU DEV Initiate

    Hi Paul,

    I've been away from work for a few days.

    It still doesn't seem to be loading the backup database to S3 even though it is connecting. I've attached a screen of the S3 bucket and a snapshot screen.

    My snapshot is set to backup sql and I'm running it manually currently.

    Many thanks,
    Nichola

  • Paul
    • The Green Incsub

    @nichola_musgrove3, For Snapshot the generation of the archive and the sending is in fact a two step process. You mentioned you are running Snapshot manually. This is fine and will generate a local zip archive.

    The sending requires the use of the built in WordPress scheduler WP_Cron. This should be automatic. For manual snapshots there is an hourly WP_Cron schedule to send files. Also if you setup a scheduled Snapshot item for once hourly, once daily, etc the archive will be created and sent on one step.

    There is no extra setup needed on your end but your system needs to have WP_Cron enabled. Again this is out of the box an automatic in most cases. Basically, Snapshot will schedule an event to run at a specific time with WP_Cron. At the given time WP_Cron will 'kick off' the snapshot function to do the actual backup and/or sending of the file.

    So the big question is does your system have WP_Cron enabled or not. For the answer go to Snapshots > Settings. You should see an ever growing section 'System Info' which lists your PHP version, within this list is a message about the WP_Cron status.

    Second WP_Cron needs traffic to your site front-end work properly.

  • nichola_musgrove3
    • WPMU DEV Initiate

    Hi,
    Thanks for this. I've installed the plugin on a site that gets traffic as the site I was using was just demo.

    In settings I have got this message about _SESSION

    Snapshot uses _SESSIONS to store temporary information about database tables and files during the backup and restore processing. Sessions are a default part of PHP.
    Session save path:
    Session save path is not a valid directory.
    Session save path is not writeable
    .

    This is fine on the other site i have used which is with a different ISP. GoDaddy haven't been very helpful with this, I thought it would be something to do with php.ini?

    Thanks, Nichola

  • Paul
    • The Green Incsub

    @nichola_musgrove3, SESSION are part of PHP and are generally on by default. The SESSION data is important only during the creation of the archive. Since your original reported problem was related to AWS can you check if the zip archive is actually being created?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.