contact form 7 file upload not working

hi

i just added contact form 7 plugin

everything works fine but i m not able to upload photo with the email for "become an expert form". i tried every thing possible, looked at the contact form 7 tutorial and followed it but no result....can you pls do it for me...the staff support is enabled

  • Adam Czajczyk
    • Support Gorilla

    Hello @siddharth123,

    I hope you're well today and thank you for your question!

    I've visited your site's dashboard and checked site's settings. I've then changed an e-mail for "Become an expert" form to my own e-mail and send a form. I did receive all the information from a form, including an image that I've attached. That said, I think the form itself is working fine.

    Have you checked your SPAM folder? Is this that there's no attachment or you're not getting an e-mail at all? Are you sure that you're not trying to upload big images (size that would come from your digital camera straight)?

    Please advise!

    Cheers,
    Adam

  • siddharth123
    • Site Builder, Child of Zeus

    i received an image that you had uploaded.

    which means that the attachment thing is working fine.

    but when i try uploading an image...the error message says..... Failed to send your message. Please try later or contact the administrator by another method.

    the mail is never sent.

    i don't know what is going wrong...and it is a very small file.

    pls help

  • Adam Czajczyk
    • Support Gorilla

    Hello @siddharth123,

    I've just checked your site's settings again and since I couldn't find anything wrong there I've run the following test:

    - I created a fresh, new page ('wpmutest')
    - added a "Become an Expert" form there
    - tried to send 6 e-mails with 3 browsers: Chrome, Opera and Firefox;
    - from each browser I tried to send a reasonably sized image and a big one (hence 2 messages per browser)

    I suppose you should receive 3 e-mails from me with the same "penguins" image attached. You'll notice which one is from which browser. Could you confirm this for me?

    It turnes out that file validation in Chrome works fine as it told me that the message coudn't be sent due to too large file. The same was in Opera though it did even hung up for a moment. In Firefox though there was no notification of any kind and the "progress wheel" kept spinning endlessly. I'm not sure if this is the reason for an issue yet but it may be an indication on where should I head on from here.

    That said, could you please also let me know what browser's and under what operating systems have you already tried? It would be also good if you could try repeating my test yourself.

    Let me know please of the results!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.