Content box and listings button not working

Hi,

There’s a couple of things I need help with first of all the listings button after adding it to a page via shortcode has this written after it: “$result = ob_get_contents(); ob_end_clean(); return $result; ”

Secondly, when you click on “Add listing” the content box where you enter your listing is broken, the whole “visual” tab is appearing lower than it should be and under the “html” buttons?

Thanks for you help! : D

  • amanda_fletcher
    • WPMU DEV Initiate

    Hi Aecnu,

    Thanks for getting back to us so quickly, it’s the directory theme, It all seems to be working now except the content box where you upload your listings, the visual tab is position incorrectly so that it appears behind the html tab? I’ve attached the screenshot so you can see!

    Many thanks!

  • aecnu
    • WP Unicorn

    Greetings amanda_fletcher,

    Thank you so much for letting me know what we are working with and that totally bizarre screen shot.

    However, I am still missing one key ingredient before getting down to the nitty gritty to figuring this out.

    What version of Directory are we working with?

    Version 2.1.2.1 or the Beta or possibly rc2?

    Please advise and we can get to work on checking this out.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings amanda_fletcher,

    Thank you for letting me know which version we are working with there which is indeed the same version I am running on my production servers.

    Unfortunately I cannot replicate the issue as shown in my screen shot below it is as it should be.

    Now it is time to go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol – first to switch to the Twenty Eleven theme just long enough to check for the problem – if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings amanda_fletcher,

    Thank you for the additional testing and input, it is greatly appreciated.

    Considering the results of your testing I would go out on a limb and say I think it is a probably a JQuery conflict between your theme and the Tiny MCE editor.

    But I am not a coder and it may be easily fixable with another or more accurately upgraded MCE Editor. Perhaps the Ultimate TinyMCE plugin may straighten this out.

    What is the name of your theme?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings amanda_fletcher,

    Thank you for your additional input, it is certainly appreciated.

    At this point we could call in the lead developer in on this ticket and see if he can indeed figure out what the conflict is.

    However, it may be in your best interest to switch to the newest upcoming version instead of having any fixes made now overwritten when the official new version comes out.

    https://premium.wpmudev.org/forums/topic/utterly-frustrated-w-directory-plugin-patience-is-wearing-thin#post-284260

    Please advise if you indeed want to continue with this version or if you have optionally chosen to try out the new upcoming cutting edge version available in the link immediately above.

    Cheers, Joe

  • amanda_fletcher
    • WPMU DEV Initiate

    Hi Joe,

    Thanks, ok so installed the new directory from the other thread as you mentioned, the content box and also thumbnails are showing up now as I wanted so that’s great! I would still like to add the search bar and banner advertising space too if possible, can you use page templates as mentioned by Kimberly? Or perhaps an additional plugin that would be able to integrate with my current set up? Thanks for your time, it’s really coming along now!

    : D

  • aecnu
    • WP Unicorn

    Greetings amanda_fletcher,

    This is certainly good news and I am happy to hear that this is moving into the direction that you want to this point, and thank you for letting me know.

    Regarding the search box at the top as well as the advertisement box, both these items are theme specific.

    Kimberly was not pointing out page templates, she was pointing out the entire theme.

    However, you may indeed want to check out the coding of that theme to perhaps use some of it for your current theme.

    This of course is custom coding and well beyond the scope of the support we provide here.

    Alternatively, you could see if there’s a developer available at wpmu jobs who could get onto it right this minute

    Or you could always approach someone like Tweaky

    Cheers, Joe

  • amanda_fletcher
    • WPMU DEV Initiate

    Hi Joe!

    Thanks for everything, I have now managed to set up a search bar another way so that’s all good. Have a new issue however, when I try to add a listing as a test user I cannot add listing it just takes me to view the listings? I was reading up on another thread where someone was experiencing something similar and they spoke about and older version of php which may be conflicting? Not sure if that’s it or not. I set up a test user account when I had the older version of directory installed and I can still add listings via that account but not with any new accounts?

    When setting up as a new user it isn’t asking for a password, just username and e-mail, do I have the wrong settings?

    Thanks again for everything! : D

  • aecnu
    • WP Unicorn

    Greetings amanda_fletcher,

    Thank you so kindly for your additional input, it is certainly appreciated.

    Could you please open another ticket with a relevant title regarding this new issue since we will probably require lead developer assistance with this and he will see this mile long thread here and need to weed through all that we have already covered and resolved.

    Please feel free to copy and paste any relevant information from this ticket into the new ticket.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.