Content Copier not copying to all sites

I am finding that Multisite Content Copier is not working reliably. Because I had some sites created before the current Blog Template, I have had to create a group for the pre-template sites and my process requires copying first to the pre-template group and then a second time to the template group.

I have just found that not all sites created with the blog template are getting the copied content. Ouch! There is no way for me to see the extent of the problem other than opening each site and checking. This is not good.

1. How can I know if the posts have been copied to all of the expected sites?
2. Is there a way to see which of the sites are included in the template "group"?
3. Please evaluate the cause of this problem and provide a fix for existing and future sites.

The website is usingessentialoils.com and I've granted access

  • Michael Bissett

    Hey @antKat, Michael here! :slight_smile:

    #1: Aside from a custom script, each blog would need to be manually checked.

    Having a log for this would be a handy thing, though, I'd advise opening a feature request for that here.
    #2: That there is, inside the Network Dashboard, you'll need to go to:

    Content Copier -> Site Groups -> Sites

    If a site has been assigned to a group, you'll see the name of it show up in the "Groups" column there.

    #3: I'm presently receiving an invalid access token error when I try logging in, though I should note, in order to debug this further, we'll need deeper access to do so.

    Could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks in advance! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @antKat,

    For some reason, WP_MEMORY_LIMIT was set to a very, very low value inside your site's wp-config.php:

    define( 'WP_MEMORY_LIMIT', '36M' );

    I've now increased the value of that, as well as WP_MAX_MEMORY_LIMIT, to 512M, just to be safe:

    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    However, when I tried creating a new site via the Network Admin Dashboard, I ran into this error when I clicked on Add Site:

    Insertion Error: Table 'fg9aw0px_ueoprd.uecom_609_affiliatereferrers' doesn't exist - The template was not applied. (New Website Templates - With CREATE TABLE query for Additional Tables)

    Unchecking the box for "uecom_101_affiliatereferrers" in the Additional Tables section for the template removed that particular error, but I now receive this:

    Insertion Error: Index column size too large. The maximum column size is 767 bytes. - The template was not applied. (New Website Templates - With CREATE TABLE query for Additional Tables)

    Even after disabling the other additional tables, I'm seeing this come up.

    I'd like to have an even deeper look at things, I'll ask for the cPanel details via email, if you could reply to that email, that'd be great. :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.